aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-tie-hash-method/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/perl-tie-hash-method/APKBUILD')
-rw-r--r--community/perl-tie-hash-method/APKBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/community/perl-tie-hash-method/APKBUILD b/community/perl-tie-hash-method/APKBUILD
index a263ac54acf..9e7630fdf99 100644
--- a/community/perl-tie-hash-method/APKBUILD
+++ b/community/perl-tie-hash-method/APKBUILD
@@ -4,7 +4,7 @@
pkgname=perl-tie-hash-method
_pkgreal=Tie-Hash-Method
pkgver=0.02
-pkgrel=0
+pkgrel=1
pkgdesc="Tied hash with specific methods overriden by callbacks"
url="http://search.cpan.org/dist/Tie-Hash-Method/"
arch="noarch"
@@ -18,7 +18,7 @@ source="http://search.cpan.org/CPAN/authors/id/Y/YV/YVES/$_pkgreal-$pkgver.tar.g
builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- default_prepare || return 1
+ default_prepare
cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
@@ -28,15 +28,18 @@ prepare() {
build() {
cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
- make && make test
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-md5sums="d7ca97ed34a31ae9dc90f666be5f1151 Tie-Hash-Method-0.02.tar.gz"
-sha256sums="d513fbb51413f7ca1e64a1bdce6194df7ec6076dea55066d67b950191eec32a9 Tie-Hash-Method-0.02.tar.gz"
sha512sums="e32e911310dfbe066167a8750f9e9a4c5b277c4666addaf3a6b00851ef47e190c88195c394b8778b38e570001ada38f00d78b2ca4fa32498bf8fbb1f94b82424 Tie-Hash-Method-0.02.tar.gz"