aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-toml/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/perl-toml/APKBUILD')
-rw-r--r--community/perl-toml/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/community/perl-toml/APKBUILD b/community/perl-toml/APKBUILD
new file mode 100644
index 00000000000..0c398d61e56
--- /dev/null
+++ b/community/perl-toml/APKBUILD
@@ -0,0 +1,35 @@
+# Automatically generated by apkbuild-cpan, template 3
+# Contributor: Timothy Legge <timlegge@gmail.com>
+# Maintainer: Timothy Legge <timlegge@gmail.com>
+pkgname=perl-toml
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
+_pkgreal=TOML
+pkgver=0.97
+pkgrel=1
+pkgdesc="Parser for Tom's Obvious, Minimal Language."
+url="https://metacpan.org/release/TOML/"
+arch="noarch"
+license="GPL-2.0-only"
+depends="perl perl-toml-parser"
+makedepends="perl-module-build-tiny perl-module-build"
+checkdepends="perl-common-sense"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/K/KA/KARUPA/TOML-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ perl Build.PL --installdirs=vendor
+ ./Build
+}
+
+check() {
+ ./Build test
+}
+
+package() {
+ ./Build install --destdir="$pkgdir"
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="96eb23e6f889119b67579340b48ed4ff089bd6600aab0d06954516a95a5017f3c042f25c9df5957312c770e39206fe03e758262e7efc0bffebb183e6287cdfb4 TOML-0.97.tar.gz"