aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-unicode-linebreak
diff options
context:
space:
mode:
Diffstat (limited to 'community/perl-unicode-linebreak')
-rw-r--r--community/perl-unicode-linebreak/APKBUILD6
1 files changed, 1 insertions, 5 deletions
diff --git a/community/perl-unicode-linebreak/APKBUILD b/community/perl-unicode-linebreak/APKBUILD
index 99ad01ec654..6a42e7179c6 100644
--- a/community/perl-unicode-linebreak/APKBUILD
+++ b/community/perl-unicode-linebreak/APKBUILD
@@ -4,7 +4,7 @@
pkgname=perl-unicode-linebreak
_pkgreal=Unicode-LineBreak
pkgver=2019.001
-pkgrel=5
+pkgrel=7
pkgdesc="UAX #14 Unicode Line Breaking Algorithm"
url="https://metacpan.org/release/Unicode-LineBreak/"
arch="all"
@@ -18,25 +18,21 @@ source="https://cpan.metacpan.org/authors/id/N/NE/NEZUMI/$_pkgreal-$pkgver.tar.g
builddir="$srcdir/$_pkgreal-$pkgver"
check() {
- cd "$builddir"
make test
}
prepare() {
default_prepare
- cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
make
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}