aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-uri-encode/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/perl-uri-encode/APKBUILD')
-rw-r--r--community/perl-uri-encode/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/community/perl-uri-encode/APKBUILD b/community/perl-uri-encode/APKBUILD
new file mode 100644
index 00000000000..6e8d13b9908
--- /dev/null
+++ b/community/perl-uri-encode/APKBUILD
@@ -0,0 +1,36 @@
+# Automatically generated by apkbuild-cpan, template 3
+# Contributor: Timothy Legge <timlegge@gmail.com>
+# Maintainer: Timothy Legge <timlegge@gmail.com>
+pkgname=perl-uri-encode
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
+_pkgreal=URI-Encode
+pkgver=1.1.1
+pkgrel=1
+pkgdesc="Simple percent Encoding/Decoding"
+url="https://metacpan.org/release/URI-Encode/"
+arch="noarch"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+depends="perl"
+makedepends="perl-module-build"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/M/MI/MITHUN/URI-Encode-v$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-v1.1.1"
+
+build() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ perl Build.PL --installdirs=vendor
+ ./Build
+}
+
+check() {
+ ./Build test
+}
+
+package() {
+ ./Build install --destdir="$pkgdir"
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="
+69290a8e2cea1bf3e826bf8686f642e73258d316371638f3dbb86abc4b8e4ed468b11e8c4219e79e13dbb5307a56a6f022b9c756b8dc75221f8d78734ddefff5 URI-Encode-v1.1.1.tar.gz
+"