aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-uri-fromhash/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/perl-uri-fromhash/APKBUILD')
-rw-r--r--community/perl-uri-fromhash/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/community/perl-uri-fromhash/APKBUILD b/community/perl-uri-fromhash/APKBUILD
new file mode 100644
index 00000000000..26a40804392
--- /dev/null
+++ b/community/perl-uri-fromhash/APKBUILD
@@ -0,0 +1,34 @@
+# Automatically generated by apkbuild-cpan, template 2
+# Contributor: Timothy Legge <timlegge@gmail.com>
+# Maintainer: Timothy Legge <timlegge@gmail.com>
+pkgname=perl-uri-fromhash
+_pkgreal=URI-FromHash
+pkgver=0.05
+pkgrel=3
+pkgdesc="Build a URI from a set of named parameters"
+url="https://metacpan.org/release/URI-FromHash/"
+arch="noarch"
+license="Artistic-2.0"
+depends="perl perl-params-validate perl-uri"
+checkdepends="perl-test-fatal"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/D/DR/DROLSKY/URI-FromHash-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="6e049a1de34c7ad94305bfb36fe37a723fe3bbd3a6bd773933e4601a75bed7a7677f12b5e8559f6c6ea3fa1fd5c6296b56541be08549277123119e13692926a7 URI-FromHash-0.05.tar.gz"