aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-urn-oasis-saml2/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/perl-urn-oasis-saml2/APKBUILD')
-rw-r--r--community/perl-urn-oasis-saml2/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/community/perl-urn-oasis-saml2/APKBUILD b/community/perl-urn-oasis-saml2/APKBUILD
new file mode 100644
index 00000000000..3b82d7f3b5d
--- /dev/null
+++ b/community/perl-urn-oasis-saml2/APKBUILD
@@ -0,0 +1,37 @@
+# Automatically generated by apkbuild-cpan, template 3
+# Contributor: Timothy Legge <timlegge@gmail.com>
+# Maintainer: Timothy Legge <timlegge@gmail.com>
+pkgname=perl-urn-oasis-saml2
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
+_pkgreal=URN-OASIS-SAML2
+pkgver=0.003
+pkgrel=1
+pkgdesc="Constants for urn:oasis SAML2 implementations"
+url="https://metacpan.org/release/URN-OASIS-SAML2/"
+arch="noarch"
+license="BSD-3-Clause"
+depends="perl"
+checkdepends="perl-test-deep"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/W/WA/WATERKIP/URN-OASIS-SAML2-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="
+de331857e77c66c7705563e8dd98e372193ca18306738ced34e216fbfd9c74878728bfd1c2942a4e5cfc2a58b7b8df2586951293d77116ad8e7a1f46e1897364 URN-OASIS-SAML2-0.003.tar.gz
+"