aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-www-mechanize/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/perl-www-mechanize/APKBUILD')
-rw-r--r--community/perl-www-mechanize/APKBUILD28
1 files changed, 19 insertions, 9 deletions
diff --git a/community/perl-www-mechanize/APKBUILD b/community/perl-www-mechanize/APKBUILD
index 465dcc66b3a..c8551b5643c 100644
--- a/community/perl-www-mechanize/APKBUILD
+++ b/community/perl-www-mechanize/APKBUILD
@@ -1,11 +1,11 @@
-# Automatically generated by apkbuild-cpan, template 3
+# Automatically generated by apkbuild-cpan, template 4
# Contributor: Timothy Legge <timlegge@gmail.com>
# Maintainer: Timothy Legge <timlegge@gmail.com>
pkgname=perl-www-mechanize
+pkgver=2.18
+pkgrel=0
#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
_pkgreal=WWW-Mechanize
-pkgver=2.03
-pkgrel=0
pkgdesc="Handy web browsing in a Perl object"
url="https://metacpan.org/release/WWW-Mechanize/"
arch="noarch"
@@ -15,9 +15,8 @@ depends="
perl-html-form
"
checkdepends="
- perl-http-daemon perl-test-fatal perl-test-output perl-test-deep perl-http-server-simple
- perl-test-warnings perl-path-tiny perl-test-nowarnings perl-test-taint perl-test-exception
- perl-libwww perl-test-memory-cycle perl-http-message perl-uri
+ perl-http-daemon perl-test-fatal perl-test-output perl-test-deep perl-test-warnings
+ perl-path-tiny perl-test-taint perl-libwww perl-test-memory-cycle perl-uri
"
subpackages="$pkgname-doc"
source="https://cpan.metacpan.org/authors/id/O/OA/OALDERS/WWW-Mechanize-$pkgver.tar.gz"
@@ -25,7 +24,10 @@ builddir="$srcdir/$_pkgreal-$pkgver"
build() {
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
- PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL \
+ INSTALLDIRS=vendor \
+ NO_PACKLIST=1 \
+ NO_PERLLOCAL=1
make
}
@@ -36,7 +38,15 @@ check() {
package() {
make DESTDIR="$pkgdir" install
- find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="306509f4d889596ebb9486d37b4c1906805c279dc7c02a7abca15ee46e549c38246d499d74fec9ee23aa6cdf931bab471ad2fe137efaf78d885c0857ccf78b08 WWW-Mechanize-2.03.tar.gz"
+doc() {
+ local file; find "$pkgdir" -name "*.pod" | while read -r file; do
+ amove "${file#"$pkgdir"}"
+ done
+ default_doc
+}
+
+sha512sums="
+6edc2eb69cae856ea53edfe820e8acb07aefea67400d688c12b1de21b159fde6d1c7fd80a846733a01762e5aadb8c92a05231294309d8dc59e2c28bcfca29a5f WWW-Mechanize-2.18.tar.gz
+"