aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-xml-easy/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/perl-xml-easy/APKBUILD')
-rw-r--r--community/perl-xml-easy/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/community/perl-xml-easy/APKBUILD b/community/perl-xml-easy/APKBUILD
new file mode 100644
index 00000000000..51b35136d85
--- /dev/null
+++ b/community/perl-xml-easy/APKBUILD
@@ -0,0 +1,35 @@
+# Automatically generated by apkbuild-cpan, template 2
+# Contributor: Timothy Legge <timlegge@gmail.com>
+# Maintainer: Timothy Legge <timlegge@gmail.com>
+pkgname=perl-xml-easy
+_pkgreal=XML-Easy
+pkgver=0.011
+pkgrel=3
+pkgdesc="XML processing with a clean interface"
+url="https://metacpan.org/release/XML-Easy/"
+arch="all"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+depends="perl-params-classify"
+makedepends="perl-dev perl-module-build"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/Z/ZE/ZEFRAM/XML-Easy-$pkgver.tar.gz
+ syntax_main-test.patch"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ perl Build.PL installdirs=vendor
+ ./Build
+}
+
+check() {
+ ./Build test
+}
+
+package() {
+ ./Build install destdir="$pkgdir"
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="19e325a2968cd62e255e6f4e3e870a15f84c2d69ea6a1bf457b1de25d352554285f7162c01fd1dbb363bbad6ae882bc7d49b94655a4795664a735392871b2e02 XML-Easy-0.011.tar.gz
+6696f9fdb393b39d6e58a45ce7e591bf22f8af59849b96dc947ae274420f41fe77fc8b9ff04fac15cfbc28c63a2af95bf5078ac63fd7810f2f3c954498d8615e syntax_main-test.patch"