aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-xml-simpleobject-libxml/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/perl-xml-simpleobject-libxml/APKBUILD')
-rw-r--r--community/perl-xml-simpleobject-libxml/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/community/perl-xml-simpleobject-libxml/APKBUILD b/community/perl-xml-simpleobject-libxml/APKBUILD
new file mode 100644
index 00000000000..bfd51b42e1f
--- /dev/null
+++ b/community/perl-xml-simpleobject-libxml/APKBUILD
@@ -0,0 +1,34 @@
+# Automatically generated by apkbuild-cpan, template 3
+# Contributor: Timothy Legge <timlegge@gmail.com>
+# Maintainer: Timothy Legge <timlegge@gmail.com>
+pkgname=perl-xml-simpleobject-libxml
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
+_pkgreal=XML-SimpleObject-LibXML
+pkgver=0.60
+pkgrel=2
+pkgdesc="a simple object representation of an XML-LibXML DOM object"
+url="https://metacpan.org/release/XML-SimpleObject-LibXML/"
+arch="noarch"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+depends="perl perl-xml-libxml"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/D/DB/DBRIAN/XML-SimpleObject-LibXML-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="ae7a40e0aaf4db8ebf735842f20f6b8fae8ac1cf77dc74782e7f87e3f809ca1c83cea7052fd38345796440b1ce8351e69f8a2635b72cb9c9846fe618ecc2d70e XML-SimpleObject-LibXML-0.60.tar.gz"