aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-xml-writer/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/perl-xml-writer/APKBUILD')
-rw-r--r--community/perl-xml-writer/APKBUILD20
1 files changed, 8 insertions, 12 deletions
diff --git a/community/perl-xml-writer/APKBUILD b/community/perl-xml-writer/APKBUILD
index 1e0b7c75350..196350f9008 100644
--- a/community/perl-xml-writer/APKBUILD
+++ b/community/perl-xml-writer/APKBUILD
@@ -1,37 +1,33 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=perl-xml-writer
-_realname=XML-Writer
-pkgver=0.625
+_pkgreal=XML-Writer
+pkgver=0.900
pkgrel=2
pkgdesc="Perl extension for writing XML documents"
-url="http://search.cpan.org/~josephw/XML-Writer-0.625/"
+url="https://metacpan.org/dist/XML-Writer"
arch="noarch"
license="PerlArtistic"
depends="perl"
-depends_dev=""
-makedepends="perl-dev"
-install=""
subpackages="$pkgname-doc"
-source="http://search.cpan.org/CPAN/authors/id/J/JO/JOSEPHW/$_realname-$pkgver.tar.gz"
+source="https://cpan.metacpan.org/authors/id/J/JO/JOSEPHW/XML-Writer-$pkgver.tar.gz"
-builddir="$srcdir/$_realname-$pkgver"
+builddir="$srcdir/$_pkgreal-$pkgver"
build() {
- cd "$builddir"
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd "$builddir"
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="30ad348e7f1423ce82dc0709e767d4ae384ad6e76f6444c8a12d97b1dc9c2b39e2c5bec43779bc35891942fa75f852cd26e8831dd6b5cfb9c72bc8512ca55923 XML-Writer-0.625.tar.gz"
+sha512sums="
+0856146f497194529352378bdd81462e0ffd185b2464f9995dedc3b4705f517d87960a9a473e44a0ae7095bdee0e3f0121410ea6208c3adb94636e9db0c8da2e XML-Writer-0.900.tar.gz
+"