aboutsummaryrefslogtreecommitdiffstats
path: root/community/pev/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/pev/APKBUILD')
-rw-r--r--community/pev/APKBUILD33
1 files changed, 16 insertions, 17 deletions
diff --git a/community/pev/APKBUILD b/community/pev/APKBUILD
index 0d94d70f61f..ff5bb1714c0 100644
--- a/community/pev/APKBUILD
+++ b/community/pev/APKBUILD
@@ -1,40 +1,37 @@
# Contributor: TBK <alpine@jjtc.eu>
# Maintainer: TBK <alpine@jjtc.eu>
pkgname=pev
-pkgver=0.81
+pkgver=0.82
pkgrel=0
pkgdesc="PE file analysis toolkit"
-url="http://pev.sourceforge.net/"
+url="https://github.com/mentebinaria/readpe"
arch="all"
license="GPL-2.0-or-later AND MIT AND BSD-2-Clause"
-makedepends="bsd-compat-headers linux-headers openssl-dev"
-checkdepends="bash python3-wininst"
+makedepends="bsd-compat-headers linux-headers openssl-dev>3"
+options="!check" # fixme
+checkdepends="bash perf"
subpackages="$pkgname-doc"
-source="https://sourceforge.net/projects/pev/files/pev-$pkgver/pev-$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/mentebinaria/readpe/archive/refs/tags/v$pkgver.tar.gz"
+builddir="$srcdir/readpe-$pkgver"
-case "$CARCH" in
- s390x | mips64)
- # s390x - Testing pepack /usr/lib/python3.8/distutils/command/wininst-10.0-amd64.exe... ERROR [-18]: not a PE file ((null))
- # mips64 - R [-18]: not a PE file ((null))
- options="!check" ;;
-esac
+# secfixes:
+# 0.82-r0:
+# - CVE-2021-45423
build() {
- make
+ make prefix=/usr
}
# Check() code from
# https://github.com/void-linux/void-packages/blob/master/srcpkgs/pev/template#L37
_real_check() {
- local py3_ver="3.8"
- local f
- for f in /usr/lib/python"$py3_ver"/distutils/command/*.exe; do
+ for f in /usr/lib/python3.11/distutils/command/*.exe; do
tests/run.sh pe32 "$f"
done
}
check() {
- export LD_LIBRARY_PATH=$(pwd)/src/build
+ export LD_LIBRARY_PATH="$PWD/src/build"
ln -sf ../../lib/libpe/libpe.so src/build/libpe.so.1
! _real_check | tee /dev/stderr | grep -q 'NOK$'
}
@@ -43,4 +40,6 @@ package() {
make prefix=/usr DESTDIR="$pkgdir" install
}
-sha512sums="d8ac24e4160a2aba6a0c788c2933fc8dac6e19d4446cfb45efd5ced939596453ed0fc4734f9669b3943d916201f913b5a363ecfb9419f4b30ed33baf62e2db90 pev-0.81.tar.gz"
+sha512sums="
+4ace735d785d2d1af5fb192b3041a1df42f0efce28ed9e44f746f67f1fb900c596ae602f4e19e472df6eefe81dc2c9083c715898306bc7faa6a4d45d8fe02235 pev-0.82.tar.gz
+"