aboutsummaryrefslogtreecommitdiffstats
path: root/community/phoc/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/phoc/APKBUILD')
-rw-r--r--community/phoc/APKBUILD39
1 files changed, 17 insertions, 22 deletions
diff --git a/community/phoc/APKBUILD b/community/phoc/APKBUILD
index f28f5d31e90..a61839ecfae 100644
--- a/community/phoc/APKBUILD
+++ b/community/phoc/APKBUILD
@@ -2,13 +2,12 @@
# Contributor: Danct12 <danct12@disroot.org>
# Contributor: Clayton Craft <clayton@craftyguy.net>
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Newbyte <newbie13xd@gmail.com>
+# Maintainer: team/phosh <newbie13xd@gmail.com>
pkgname=phoc
-pkgver=0.13.1
-pkgrel=0
-_wlrootsver="0.14.1-5pureos3"
+pkgver=0.38.0
+pkgrel=1
pkgdesc="wlroots based Phone compositor for the Phosh shell"
-arch="all !s390x !riscv64" # blocked by gnome-desktop
+arch="all !s390x" # blocked by gnome-desktop
url="https://gitlab.gnome.org/World/Phosh/phoc"
license="GPL-3.0-only"
depends="
@@ -18,7 +17,9 @@ depends="
"
_wlrootsmakedepends="
eudev-dev
+ hwdata-dev
libcap-dev
+ libdisplay-info-dev
libseat-dev
libxcb-dev
xcb-util-image-dev
@@ -30,7 +31,7 @@ _wlrootsmakedepends="
makedepends="
glib-dev
gnome-desktop-dev
- gsettings-desktop-schemas
+ json-glib-dev
libdrm-dev
libinput-dev
libxkbcommon-dev
@@ -45,34 +46,28 @@ checkdepends="xvfb-run"
subpackages="$pkgname-dbg"
options="!check" # Needs fullblown EGL
source="
- https://gitlab.gnome.org/World/Phosh/phoc/-/archive/v$pkgver/phoc-v$pkgver.tar.gz
- https://source.puri.sm/Librem5/wlroots/-/archive/pureos/$_wlrootsver/wlroots-pureos-$_wlrootsver.tar.gz
+ https://sources.phosh.mobi/releases/phoc/phoc-$pkgver.tar.xz
"
replaces="wlroots-phosh"
-builddir="$srcdir/$pkgname-v$pkgver"
-
prepare() {
default_prepare
- rm -rf "$builddir/subprojects/wlroots"
- ln -s "$srcdir/wlroots-pureos-$_wlrootsver" "$builddir/subprojects/wlroots"
-
- # apply wlroots patches
- cd "$builddir/subprojects/wlroots"
- grep "\.patch$" debian/patches/series | \
- xargs -I {} -t -r -n1 patch -p1 -i debian/patches/{}
+ patch -Np1 < subprojects/packagefiles/wlroots/0001-Revert-layer-shell-error-on-0-dimension-without-anch.patch -d subprojects/wlroots
}
build() {
abuild-meson \
+ -Db_lto=true \
-Dembed-wlroots=enabled \
+ -Dtests="$(want_check && echo true || echo false)" \
+ --default-library=static \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- xvfb-run meson test --no-rebuild -v -C output
+ xvfb-run -a meson test --no-rebuild --print-errorlogs -C output
}
package() {
@@ -82,10 +77,10 @@ package() {
# remove unneeded wlroots dev. files
rm -r "$pkgdir"/usr/include
- rm -r "$pkgdir"/usr/lib/libwlroots.so
+ rm -r "$pkgdir"/usr/lib/libwlroots.a
rm -r "$pkgdir"/usr/lib/pkgconfig
}
+
sha512sums="
-0da68ac4d0601e91ed5f59eeb0beea64180b546f58b300631495084d366fe515c26fe9d58d0ca20687032f6824ae98dcc82edd8a6c80caa95178d24d27ee2650 phoc-v0.13.1.tar.gz
-337af0efb88f0e372af90fc5644b064d5563d68d18efc73ecd398a1d5675b37c2b3499051dd247794cf2b6ac020c8c92949cbd74743760eedab59004f447f9db wlroots-pureos-0.14.1-5pureos3.tar.gz
+739fb382336885b78ca3f50f8c5f6ddf3bc308a2158663c49c84ce506d2edf0c8d0dcd412e634eccf848d420bb5923d42ebc02044f7acf322b3ab621ffa4cd23 phoc-0.38.0.tar.xz
"