aboutsummaryrefslogtreecommitdiffstats
path: root/community/phosh-antispam/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/phosh-antispam/APKBUILD')
-rw-r--r--community/phosh-antispam/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/community/phosh-antispam/APKBUILD b/community/phosh-antispam/APKBUILD
new file mode 100644
index 00000000000..6f79047ef8a
--- /dev/null
+++ b/community/phosh-antispam/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Clayton Craft <clayton@craftyguy.net>
+# Maintainer: Clayton Craft <clayton@craftyguy.net>
+pkgname=phosh-antispam
+pkgver=3.4
+pkgrel=0
+pkgdesc="monitors Gnome Calls and manages phone calls from unidentified/unknown callers"
+url="https://gitlab.com/kop316/phosh-antispam"
+arch="all"
+license="GPL-3.0-or-later"
+depends="calls>=41_beta"
+makedepends="
+ desktop-file-utils
+ glib-dev
+ gtk4.0-dev
+ libadwaita-dev
+ meson
+ "
+source="https://gitlab.com/kop316/phosh-antispam/-/archive/$pkgver/phosh-antispam-$pkgver.tar.gz
+ 0001-fix-tests.patch
+"
+
+build() {
+ abuild-meson . output
+ meson compile -C output
+}
+
+check() {
+ meson test --no-rebuild --print-errorlogs -C output
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
+}
+
+sha512sums="
+e301e3c3ac08926dc3340c1af86be21f26a1761ac31971c8dab5ce7610c6f879c32bdb753634b58b4dba9ed3e479a191701a3d9cc4ea2c66c1530b24c358d41e phosh-antispam-3.4.tar.gz
+3e292ce91896b847b25fd133292151e46e7fdf69ead1ab6e19a868ef71da2a2993b6f9e2249a38c53fb7f344c1e1e1ef3021fb304bc63015abb8679bc373d8ec 0001-fix-tests.patch
+"