aboutsummaryrefslogtreecommitdiffstats
path: root/community/phosh-antispam/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/phosh-antispam/APKBUILD')
-rw-r--r--community/phosh-antispam/APKBUILD24
1 files changed, 16 insertions, 8 deletions
diff --git a/community/phosh-antispam/APKBUILD b/community/phosh-antispam/APKBUILD
index 3402185d5d1..6f79047ef8a 100644
--- a/community/phosh-antispam/APKBUILD
+++ b/community/phosh-antispam/APKBUILD
@@ -1,24 +1,31 @@
# Contributor: Clayton Craft <clayton@craftyguy.net>
# Maintainer: Clayton Craft <clayton@craftyguy.net>
pkgname=phosh-antispam
-pkgver=2.0
+pkgver=3.4
pkgrel=0
pkgdesc="monitors Gnome Calls and manages phone calls from unidentified/unknown callers"
url="https://gitlab.com/kop316/phosh-antispam"
-arch="all !s390x !riscv64" # no libhandy1
+arch="all"
license="GPL-3.0-or-later"
depends="calls>=41_beta"
-makedepends="meson glib-dev gtk+3.0-dev libhandy1-dev"
-subpackages="$pkgname-doc $pkgname-lang $pkgname-bash-completion"
-source="https://gitlab.com/kop316/phosh-antispam/-/archive/$pkgver/phosh-antispam-$pkgver.tar.gz"
+makedepends="
+ desktop-file-utils
+ glib-dev
+ gtk4.0-dev
+ libadwaita-dev
+ meson
+ "
+source="https://gitlab.com/kop316/phosh-antispam/-/archive/$pkgver/phosh-antispam-$pkgver.tar.gz
+ 0001-fix-tests.patch
+"
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
@@ -26,5 +33,6 @@ package() {
}
sha512sums="
-57a9f3777127549d2fb0900d003db19c1722464c3449799e225e42672fd1d230a34b2f234175dc23bf4994171d35c081882efcea7e66dda707e0b9888983c5a8 phosh-antispam-2.0.tar.gz
+e301e3c3ac08926dc3340c1af86be21f26a1761ac31971c8dab5ce7610c6f879c32bdb753634b58b4dba9ed3e479a191701a3d9cc4ea2c66c1530b24c358d41e phosh-antispam-3.4.tar.gz
+3e292ce91896b847b25fd133292151e46e7fdf69ead1ab6e19a868ef71da2a2993b6f9e2249a38c53fb7f344c1e1e1ef3021fb304bc63015abb8679bc373d8ec 0001-fix-tests.patch
"