aboutsummaryrefslogtreecommitdiffstats
path: root/community/phosh/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/phosh/APKBUILD')
-rw-r--r--community/phosh/APKBUILD52
1 files changed, 30 insertions, 22 deletions
diff --git a/community/phosh/APKBUILD b/community/phosh/APKBUILD
index 9f5d8ea5802..93f53d1f7fd 100644
--- a/community/phosh/APKBUILD
+++ b/community/phosh/APKBUILD
@@ -1,86 +1,94 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Contributor: Danct12 <danct12@disroot.org>
# Contributor: Newbyte <newbyte@disroot.org>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Newbyte <newbyte@postmarketos.org>
pkgname=phosh
-pkgver=0.17.0
-pkgrel=4
-pkgdesc="Shell PoC for the Librem5"
+pkgver=0.37.0
+pkgrel=2
+pkgdesc="Wayland shell for GNOME on mobile devices"
+# armhf: blocked by gnome-shell-schemas
# Blocked on s390x by gnome-session, gnome-settings-daemon, squeekboard and libhandy
# Blocked on ppc64le by gnome-session
-# riscv64 disabled due to missing rust in recursive dependency
-arch="all !s390x !ppc64le !riscv64"
+arch="all !armhf !s390x !ppc64le"
url="https://gitlab.gnome.org/World/Phosh/phosh"
license="GPL-3.0-only"
+triggers="$pkgname.trigger=/usr/lib/phosh/plugins/prefs"
depends="
+ adwaita-icon-theme
bash
dbus-x11
dbus:org.freedesktop.Secrets
+ desktop-file-utils
font-adobe-source-code-pro
+ font-cantarell
gnome-control-center
gnome-session
gnome-settings-daemon
gnome-shell-schemas
- adwaita-icon-theme
- gnome-themes-extra
gsettings-desktop-schemas
phoc
- squeekboard
- ttf-cantarell
+ phosh-keyboard
xwayland
"
makedepends="
callaudiod-dev
elogind-dev
+ evince-dev
+ evolution-data-server-dev
feedbackd-dev
gcr-dev
gettext-dev
glib-dev
gnome-desktop-dev
gtk+3.0-dev
+ libadwaita-dev
libgudev-dev
libhandy1-dev
libsecret-dev
linux-pam-dev
- networkmanager-dev
meson
+ networkmanager-dev
polkit-elogind-dev
pulseaudio-dev
+ py3-docutils
upower-dev
wayland-dev
wayland-protocols
"
checkdepends="xvfb-run"
-subpackages="$pkgname-dbg $pkgname-lang"
+subpackages="$pkgname-dbg $pkgname-lang $pkgname-dev $pkgname-doc $pkgname-portalsconf"
source="https://download.gnome.org/sources/phosh/${pkgver%.*}/phosh-$pkgver.tar.xz
phosh.desktop
- sm.puri.OSK0.desktop
"
build() {
# phoc tests need a running Wayland compositor
abuild-meson \
+ -Db_lto=true \
-Dphoc_tests=disabled \
+ -Dman=true \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- xvfb-run meson test --no-rebuild -v -C output
+ xvfb-run -a meson test --no-rebuild --print-errorlogs -C output
}
package() {
- DESTDIR="$pkgdir/" meson install --no-rebuild -C output
+ DESTDIR="$pkgdir/" meson install --no-rebuild --skip-subprojects -C output
install -D -m644 "$srcdir"/phosh.desktop \
"$pkgdir"/usr/share/wayland-sessions/phosh.desktop
+}
- install -D -m644 "$srcdir"/sm.puri.OSK0.desktop \
- "$pkgdir"/usr/share/applications/sm.puri.OSK0.desktop
-
+portalsconf() {
+ install_if="$pkgname=$pkgver-r$pkgrel xdg-desktop-portal>=1.17.1"
+ amove usr/share/xdg-desktop-portal/phosh-portals.conf
}
+
sha512sums="
-38bd9883636ec67f747766545117f37d52b60a86d44b27a460b31767ff3b6dc7ec6dd841eb3343a250631a786b0d0bed1667308029bfb9680a1465fc97b3503a phosh-0.17.0.tar.xz
-aef856033ae17bc8e18963ea56aad34e6e0d262d0060f9b5aa9f072c7598d531ee9a55b189d6fadf7e6f3c5dd113b77de51a64bcf17ad5764ff57a4be8472dc7 phosh.desktop
-52a670893bd5027d6a45d7ff18258d634dc5d98371a7cdc094261ccc12a15d0b46e96d572ae8882ae27eb90418f2dc4f0fb1a45ce95f8d70eadc51d284780916 sm.puri.OSK0.desktop
+3f1c1eb1925909b04e416f6a56d92500465965e70f1e89a8e8963aa3339165f397238971661ac3fcc8b9143245e418b5f400257a7fe0df28160ca8a03cf3107b phosh-0.37.0.tar.xz
+8ca4893a751311de326e198314669f5a276092ade99c6353c4c9ce070713fb1a5b1615e7fecb93b428dc79fd4001a9af43d24eafaf2545d7db464963fda25330 phosh.desktop
"