aboutsummaryrefslogtreecommitdiffstats
path: root/community/phosh/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/phosh/APKBUILD')
-rw-r--r--community/phosh/APKBUILD114
1 files changed, 71 insertions, 43 deletions
diff --git a/community/phosh/APKBUILD b/community/phosh/APKBUILD
index ab2ee26c4e2..7f0cc413090 100644
--- a/community/phosh/APKBUILD
+++ b/community/phosh/APKBUILD
@@ -1,67 +1,95 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Contributor: Danct12 <danct12@disroot.org>
# Contributor: Newbyte <newbyte@disroot.org>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: team/phosh <newbyte@postmarketos.org>
pkgname=phosh
-pkgver=0.13.1
-pkgrel=2
-_commit_gvc="ae1a34aafce7026b8c0f65a43c9192d756fe1057"
-_commit_libcall_ui="465f6add090b623fb80c6c5cbb9ab2880ff531a4"
-pkgdesc="Shell PoC for the Librem5"
-# Blocked on mips and s390x by gnome-session, gnome-settings-daemon, squeekboard and libhandy
+pkgver=0.38.0
+pkgrel=1
+pkgdesc="Wayland shell for GNOME on mobile devices"
+# armhf: blocked by gnome-shell-schemas
+# Blocked on s390x by gnome-session, gnome-settings-daemon, squeekboard and libhandy
# Blocked on ppc64le by gnome-session
-# riscv64 disabled due to missing rust in recursive dependency
-arch="all !s390x !ppc64le !mips !mips64 !riscv64"
+arch="all !armhf !s390x !ppc64le"
url="https://gitlab.gnome.org/World/Phosh/phosh"
license="GPL-3.0-only"
-depends="phoc gnome-session bash dbus-x11 gnome-settings-daemon
- squeekboard libpulse dbus:org.freedesktop.Secrets gnome-control-center"
-makedepends="gtk+3.0-dev meson ninja gnome-desktop-dev callaudiod-dev libgudev-dev libhandy1-dev gcr-dev upower-dev
- linux-pam-dev git cmake pulseaudio-dev networkmanager-dev polkit-elogind-dev
- libsecret-dev feedbackd-dev elogind-dev wayland-protocols"
-subpackages="$pkgname-lang"
-source="$pkgname-$pkgver.tar.gz::$url/-/archive/v$pkgver/phosh-v$pkgver.tar.gz
- https://gitlab.gnome.org/GNOME/libgnome-volume-control/-/archive/$_commit_gvc/gvc-$_commit_gvc.tar.gz
- https://gitlab.gnome.org/World/Phosh/libcall-ui/-/archive/$_commit_libcall_ui/libcall-ui-$_commit_libcall_ui.tar.gz
+triggers="$pkgname.trigger=/usr/lib/phosh/plugins/prefs"
+depends="
+ adwaita-icon-theme
+ bash
+ dbus-x11
+ dbus:org.freedesktop.Secrets
+ desktop-file-utils
+ font-adobe-source-code-pro
+ font-cantarell
+ gnome-control-center
+ gnome-session
+ gnome-settings-daemon
+ gnome-shell-schemas
+ gsettings-desktop-schemas
+ phoc
+ phosh-keyboard
+ xwayland
+ "
+makedepends="
+ callaudiod-dev
+ elogind-dev
+ evince-dev
+ evolution-data-server-dev
+ feedbackd-dev
+ gcr-dev
+ gettext-dev
+ glib-dev
+ gnome-desktop-dev
+ gtk+3.0-dev
+ libadwaita-dev
+ libgudev-dev
+ libhandy1-dev
+ libsecret-dev
+ linux-pam-dev
+ meson
+ networkmanager-dev
+ polkit-elogind-dev
+ pulseaudio-dev
+ py3-docutils
+ upower-dev
+ wayland-dev
+ wayland-protocols
+ "
+checkdepends="xvfb-run"
+subpackages="$pkgname-dbg $pkgname-lang $pkgname-dev $pkgname-doc $pkgname-portalsconf"
+source="https://download.gnome.org/sources/phosh/${pkgver%.*}/phosh-$pkgver.tar.xz
phosh.desktop
- sm.puri.OSK0.desktop
"
-options="!check" # Needs a running Wayland compositor
-builddir="$srcdir/$pkgname-v$pkgver"
-
-prepare() {
- default_prepare
- subproject_path="$builddir"/subprojects
- gvc_path="$subproject_path"/gvc
- cui_path="$subproject_path"/libcall-ui
- mkdir -p $gvc_path $cui_path
- mv "$srcdir"/libgnome-volume-control-"$_commit_gvc"/* $gvc_path
- mv "$srcdir"/libcall-ui-"$_commit_libcall_ui"/* $cui_path
-}
build() {
- abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ # phoc tests need a running Wayland compositor
+ abuild-meson \
+ -Db_lto=true \
+ -Dphoc_tests=disabled \
+ -Dsystemd=false \
+ -Dman=true \
+ . output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ xvfb-run -a meson test --no-rebuild --print-errorlogs -C output
}
package() {
- DESTDIR="$pkgdir/" meson install --no-rebuild -C output
+ DESTDIR="$pkgdir/" meson install --no-rebuild --skip-subprojects -C output
install -D -m644 "$srcdir"/phosh.desktop \
"$pkgdir"/usr/share/wayland-sessions/phosh.desktop
+}
- install -D -m644 "$srcdir"/sm.puri.OSK0.desktop \
- "$pkgdir"/usr/share/applications/sm.puri.OSK0.desktop
-
+portalsconf() {
+ install_if="$pkgname=$pkgver-r$pkgrel xdg-desktop-portal>=1.17.1"
+ amove usr/share/xdg-desktop-portal/phosh-portals.conf
}
+
sha512sums="
-fcb25f8dfc5b90c52b0463899a9c9968658e955519d86873cf3d056a0e74da657165092324cc943ce438eeac54b27a77267d4b3c58710d10c899cb43f42703ad phosh-0.13.1.tar.gz
-723334bff55927363dab47ef22c71dcaf94263fe76e49c40f1cbfbd5f86383e68fd4bf2182eb5777dda8e2ede4ee4710e1a7ab1379d3ca40d68f68ff30c62e21 gvc-ae1a34aafce7026b8c0f65a43c9192d756fe1057.tar.gz
-d11de7b15777f175d0a2323cd7b6a07f76b1ccd1e01a4948084b2e950f356f80357604dd95853c60fa49c812d2e981d0899ade1ce7d933f0f9e32fc8c44807eb libcall-ui-465f6add090b623fb80c6c5cbb9ab2880ff531a4.tar.gz
-aef856033ae17bc8e18963ea56aad34e6e0d262d0060f9b5aa9f072c7598d531ee9a55b189d6fadf7e6f3c5dd113b77de51a64bcf17ad5764ff57a4be8472dc7 phosh.desktop
-52a670893bd5027d6a45d7ff18258d634dc5d98371a7cdc094261ccc12a15d0b46e96d572ae8882ae27eb90418f2dc4f0fb1a45ce95f8d70eadc51d284780916 sm.puri.OSK0.desktop
+dfde54b64ea6edba2b66dfe2f5ff0f4b3edbb192b1a37fbc8c98d9365bdedc5d19ddb1464673e516cb8e436a6c0ea00c84087cc6431b6c1862019f90e02b73ce phosh-0.38.0.tar.xz
+8ca4893a751311de326e198314669f5a276092ade99c6353c4c9ce070713fb1a5b1615e7fecb93b428dc79fd4001a9af43d24eafaf2545d7db464963fda25330 phosh.desktop
"