aboutsummaryrefslogtreecommitdiffstats
path: root/community/php7-pecl-ast/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/php7-pecl-ast/APKBUILD')
-rw-r--r--community/php7-pecl-ast/APKBUILD38
1 files changed, 0 insertions, 38 deletions
diff --git a/community/php7-pecl-ast/APKBUILD b/community/php7-pecl-ast/APKBUILD
deleted file mode 100644
index 3849a95d0ef..00000000000
--- a/community/php7-pecl-ast/APKBUILD
+++ /dev/null
@@ -1,38 +0,0 @@
-# Contributor: Andy Blyler <andy@blyler.cc>
-# Maintainer: Fabio Ribeiro <fabiorphp@gmail.com>
-pkgname=php7-pecl-ast
-_extname=ast
-pkgver=1.0.14
-pkgrel=0
-pkgdesc="PHP extension exposing PHP 7 abstract syntax tree - PECL"
-url="https://pecl.php.net/package/ast"
-arch="all"
-license="BSD-3-Clause"
-depends="php7-common"
-makedepends="php7-dev"
-source="php-pecl-$_extname-$pkgver.tar.gz::https://pecl.php.net/get/$_extname-$pkgver.tgz"
-builddir="$srcdir"/$_extname-$pkgver
-provides="php7-ast=$pkgver-r$pkgrel" # for backward compatibility
-replaces="php7-ast" # for backward compatibility
-
-build() {
- phpize7
- ./configure --prefix=/usr \
- --with-php-config=/usr/bin/php-config7
- make
-}
-
-check() {
- make NO_INTERACTION=1 REPORT_EXIT_STATUS=1 test TESTS=--show-diff
-}
-
-package() {
- make INSTALL_ROOT="$pkgdir" install
- local _confdir="$pkgdir"/etc/php7/conf.d
- install -d $_confdir
- echo "extension=$_extname" > $_confdir/$_extname.ini
-}
-
-sha512sums="
-12cdb4fd864380dba0887b59986a388af49bff782cbea31b71fa0932920a328c8c1d1bda43b23f3b42645cfee38f8198bd739379fa6dc9fc60a89541b52f9336 php-pecl-ast-1.0.14.tar.gz
-"