aboutsummaryrefslogtreecommitdiffstats
path: root/community/php7-pecl-protobuf/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/php7-pecl-protobuf/APKBUILD')
-rw-r--r--community/php7-pecl-protobuf/APKBUILD36
1 files changed, 0 insertions, 36 deletions
diff --git a/community/php7-pecl-protobuf/APKBUILD b/community/php7-pecl-protobuf/APKBUILD
deleted file mode 100644
index 2af7a70f149..00000000000
--- a/community/php7-pecl-protobuf/APKBUILD
+++ /dev/null
@@ -1,36 +0,0 @@
-# Contributor: TBK <alpine@jjtc.eu>
-# Maintainer: TBK <alpine@jjtc.eu>
-pkgname=php7-pecl-protobuf
-_extname=protobuf
-pkgver=3.14.0
-pkgrel=0
-pkgdesc="PHP7 extension: Google's language-neutral, platform-neutral, extensible mechanism for serializing structured data."
-url="https://pecl.php.net/package/protobuf"
-arch="all"
-license="BSD-3-Clause"
-depends="php7-common"
-makedepends="php7-dev autoconf libtool"
-source="https://pecl.php.net/get/$_extname-$pkgver.tgz"
-builddir="$srcdir/$_extname-$pkgver"
-provides="php7-protobuf=$pkgver-r$pkgrel" # for backward compatibility
-replaces="php7-protobuf" # for backward compatibility
-
-build() {
- phpize7
- ./configure --prefix=/usr --with-php-config=php-config7
- make
-}
-
-check() {
- # Test suite is not a part of pecl release.
- php7 -d extension=modules/$_extname.so --ri $_extname
-}
-
-package() {
- make INSTALL_ROOT="$pkgdir" install
- local _confdir="$pkgdir"/etc/php7/conf.d
- install -d $_confdir
- echo "extension=$_extname.so" > $_confdir/$_extname.ini
-}
-
-sha512sums="5bf8fa8da35ad9159d712d2964ed4b984b35bc1912acca4248994d845f6efd886cfe5b81566da93230d6138e27a774dcd1c144d48efd7685f5b52c7e00dafa22 protobuf-3.14.0.tgz"