aboutsummaryrefslogtreecommitdiffstats
path: root/community/php7-pecl-protobuf/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/php7-pecl-protobuf/APKBUILD')
-rw-r--r--community/php7-pecl-protobuf/APKBUILD38
1 files changed, 0 insertions, 38 deletions
diff --git a/community/php7-pecl-protobuf/APKBUILD b/community/php7-pecl-protobuf/APKBUILD
deleted file mode 100644
index 8dcf1e43c37..00000000000
--- a/community/php7-pecl-protobuf/APKBUILD
+++ /dev/null
@@ -1,38 +0,0 @@
-# Contributor: TBK <alpine@jjtc.eu>
-# Maintainer: TBK <alpine@jjtc.eu>
-pkgname=php7-pecl-protobuf
-_extname=protobuf
-pkgver=3.18.1
-pkgrel=0
-pkgdesc="PHP 7 extension: Google's language-neutral, platform-neutral, extensible mechanism for serializing structured data."
-url="https://pecl.php.net/package/protobuf"
-arch="all"
-license="BSD-3-Clause"
-depends="php7-common"
-makedepends="php7-dev"
-source="php-pecl-$_extname-$pkgver.tgz::https://pecl.php.net/get/$_extname-$pkgver.tgz"
-builddir="$srcdir/$_extname-$pkgver"
-provides="php7-protobuf=$pkgver-r$pkgrel" # for backward compatibility
-replaces="php7-protobuf" # for backward compatibility
-
-build() {
- phpize7
- ./configure --prefix=/usr --with-php-config=php-config7
- make
-}
-
-check() {
- # Test suite is not a part of pecl release.
- php7 -d extension=modules/$_extname.so --ri $_extname
-}
-
-package() {
- make INSTALL_ROOT="$pkgdir" install
- local _confdir="$pkgdir"/etc/php7/conf.d
- install -d $_confdir
- echo "extension=$_extname" > $_confdir/$_extname.ini
-}
-
-sha512sums="
-2f83cd204d902e9c67fc3a9120405f2140e2edb2169dcb4a70012c3875dd80d2ad8aa144ec2f43bec31ee11e78a4f5363b63a962c94f6973a0eec78dc5158aa4 php-pecl-protobuf-3.18.1.tgz
-"