aboutsummaryrefslogtreecommitdiffstats
path: root/community/php7-pecl-xdebug/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/php7-pecl-xdebug/APKBUILD')
-rw-r--r--community/php7-pecl-xdebug/APKBUILD44
1 files changed, 0 insertions, 44 deletions
diff --git a/community/php7-pecl-xdebug/APKBUILD b/community/php7-pecl-xdebug/APKBUILD
deleted file mode 100644
index 7e7c1a6af43..00000000000
--- a/community/php7-pecl-xdebug/APKBUILD
+++ /dev/null
@@ -1,44 +0,0 @@
-# Contributor: Andy Postnikov <apostnikov@gmail.com>
-# Contributor: Valery Kartel <valery.kartel@gmail.com>
-# Contributor: Fabio Ribeiro <fabiorphp@gmail.com>
-# Maintainer: Andy Postnikov <apostnikov@gmail.com>
-pkgname=php7-pecl-xdebug
-_pkgname=xdebug
-pkgver=2.9.2
-pkgrel=0
-pkgdesc="PHP extension that provides functions for function traces and profiling - PECL"
-url="https://pecl.php.net/package/xdebug"
-arch="all"
-license="PHP-3.0"
-depends="php7-common"
-makedepends="php7-dev autoconf re2c"
-source="$pkgname-$pkgver.tgz::https://pecl.php.net/get/$_pkgname-$pkgver.tgz"
-builddir="$srcdir/$_pkgname-$pkgver"
-provides="php7-xdebug=$pkgver-r$pkgrel" # for backward compatibility
-replaces="php7-xdebug" # for backward compatibility
-
-build() {
- phpize7
- ./configure --prefix=/usr --with-php-config=php-config7
- make
-}
-
-check() {
- # PECL package has no test suite.
- php7 -z "$builddir"/modules/xdebug.so -r "in_array('Xdebug', get_loaded_extensions(true)) ? exit(0) : exit(1);"
-}
-
-package() {
- local confdir="$pkgdir/etc/php7/conf.d"
-
- make INSTALL_ROOT="$pkgdir" install
- install -D -m644 contrib/tracefile-analyser.php "$pkgdir"/usr/share/php7/xdebug/tracefile-analyser.php
-
- mkdir -p "$confdir"
- cat > "$confdir"/$_pkgname.ini <<-EOF
- ; Uncomment to enable this extension.
- ;zend_extension=$_pkgname.so
- EOF
-}
-
-sha512sums="87de15d3ca82298a404e7b9f3a18efa50d6204c5b9dec499662adf43985d2aa58da352afdb3e8c753713974d902d9c9af033359ff7ac55e40b0c3315b6e1ba6e php7-pecl-xdebug-2.9.2.tgz"