aboutsummaryrefslogtreecommitdiffstats
path: root/community/php7-pecl-xhprof/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/php7-pecl-xhprof/APKBUILD')
-rw-r--r--community/php7-pecl-xhprof/APKBUILD56
1 files changed, 0 insertions, 56 deletions
diff --git a/community/php7-pecl-xhprof/APKBUILD b/community/php7-pecl-xhprof/APKBUILD
deleted file mode 100644
index 3fc938fa517..00000000000
--- a/community/php7-pecl-xhprof/APKBUILD
+++ /dev/null
@@ -1,56 +0,0 @@
-# Contributor: Andy Postnikov <apostnikov@gmail.com>
-# Maintainer: Andy Postnikov <apostnikov@gmail.com>
-
-pkgname=php7-pecl-xhprof
-_extname=xhprof
-pkgver=2.3.3
-pkgrel=0
-pkgdesc="A Hierarchical Profiler for PHP 7 - PECL"
-url="https://pecl.php.net/package/xhprof"
-arch="all"
-license="Apache-2.0"
-depends="php7-common"
-makedepends="php7-dev"
-_assetsdepends="php7-ctype graphviz ghostscript-fonts"
-subpackages="$pkgname-assets::noarch"
-source="php-pecl-$_extname-$pkgver.tgz::https://pecl.php.net/get/$_extname-$pkgver.tgz"
-builddir="$srcdir/$_extname-$pkgver/extension"
-provides="php7-xhprof=$pkgver-r$pkgrel" # for backward compatibility
-replaces="php7-xhprof" # for backward compatibility
-
-build() {
- phpize7
- ./configure --with-php-config=php-config7
- make
-}
-
-check() {
- make NO_INTERACTION=1 REPORT_EXIT_STATUS=1 test TESTS=--show-diff
-}
-
-package() {
- make INSTALL_ROOT="$pkgdir" install
- local _confdir="$pkgdir"/etc/php7/conf.d
- install -d $_confdir
- cat > $_confdir/$_extname.ini <<-EOF
- extension=$_extname
- xhprof.output_dir=/tmp
- EOF
-}
-
-assets() {
- pkgdesc="A Hierarchical Profiler for PHP (UI assets)"
- depends="$_assetsdepends"
- provides="php7-xhprof-assets=$pkgver-r$pkgrel" # for backward compatibility
- replaces="php7-xhprof-assets" # for backward compatibility
-
- local _assetsdir="$subpkgdir"/usr/share/php7/xhprof
- install -d $_assetsdir
- cp -R "$builddir"/../xhprof_lib $_assetsdir
- cp -R "$builddir"/../xhprof_html $_assetsdir
- cp -R "$builddir"/../examples $_assetsdir
-}
-
-sha512sums="
-898229f795c2fc630aabe5627eb2f69494962623de9582b345ced20220b62a24084438952beab92cd7f86019683b880131169eb0c916e45dc512f104ef0c7517 php-pecl-xhprof-2.3.3.tgz
-"