aboutsummaryrefslogtreecommitdiffstats
path: root/community/php7-pecl-xhprof/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/php7-pecl-xhprof/APKBUILD')
-rw-r--r--community/php7-pecl-xhprof/APKBUILD58
1 files changed, 0 insertions, 58 deletions
diff --git a/community/php7-pecl-xhprof/APKBUILD b/community/php7-pecl-xhprof/APKBUILD
deleted file mode 100644
index abe027d9aee..00000000000
--- a/community/php7-pecl-xhprof/APKBUILD
+++ /dev/null
@@ -1,58 +0,0 @@
-# Contributor: Andy Postnikov <apostnikov@gmail.com>
-# Maintainer: Andy Postnikov <apostnikov@gmail.com>
-
-pkgname=php7-pecl-xhprof
-_extname=xhprof
-pkgver=2.2.2
-pkgrel=0
-pkgdesc="A Hierarchical Profiler for PHP"
-url="https://pecl.php.net/package/xhprof"
-arch="all"
-license="Apache-2.0"
-depends="php7-ctype"
-makedepends="php7-dev"
-subpackages="$pkgname-assets::noarch"
-source="$pkgname-$pkgver.tar.gz::https://pecl.php.net/get/$_extname-$pkgver.tgz"
-builddir="$srcdir/$_extname-$pkgver"
-provides="php7-xhprof=$pkgver-r$pkgrel" # for backward compatibility
-replaces="php7-xhprof" # for backward compatibility
-
-build() {
- cd "$builddir"/extension
- phpize7
- ./configure --with-php-config=php-config7
- make
-}
-
-check() {
- cd "$builddir"/extension
- make NO_INTERACTION=1 REPORT_EXIT_STATUS=1 test TESTS=--show-diff
-}
-
-package() {
- cd "$builddir"/extension
- make INSTALL_ROOT="$pkgdir"/ install
- local _confdir="$pkgdir"/etc/php7/conf.d
- install -d $_confdir
- cat > $_confdir/$_extname.ini <<-EOF
- extension=$_extname.so
- xhprof.output_dir=/tmp
- EOF
- local _assetsdir="$pkgdir"/usr/share/php7/xhprof
- install -d $_assetsdir
- cp -R "$builddir"/xhprof_lib $_assetsdir
-}
-
-assets() {
- pkgdesc="A Hierarchical Profiler for PHP (UI assets)"
- depends="$pkgname graphviz ghostscript-fonts"
- provides="php7-xhprof-assets=$pkgver-r$pkgrel" # for backward compatibility
- replaces="php7-xhprof-assets" # for backward compatibility
-
- local _assetsdir="$subpkgdir"/usr/share/php7/xhprof
- install -d $_assetsdir
- cp -R "$builddir"/xhprof_html $_assetsdir
- cp -R "$builddir"/examples $_assetsdir
-}
-
-sha512sums="211de35f91d721f44ad5f3da9fe616a8d1cadedbc39537d5052ee7ce9096c0bb40b589778b8ded5b17e1896e6fbb0d716aca551c2ef6e8580c8f7bf21530796c php7-pecl-xhprof-2.2.2.tar.gz"