aboutsummaryrefslogtreecommitdiffstats
path: root/community/php7-pecl-yaml/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/php7-pecl-yaml/APKBUILD')
-rw-r--r--community/php7-pecl-yaml/APKBUILD37
1 files changed, 0 insertions, 37 deletions
diff --git a/community/php7-pecl-yaml/APKBUILD b/community/php7-pecl-yaml/APKBUILD
deleted file mode 100644
index 36616be0203..00000000000
--- a/community/php7-pecl-yaml/APKBUILD
+++ /dev/null
@@ -1,37 +0,0 @@
-# Maintainer: Renoir Boulanger <hello@renoirboulanger.com>
-pkgname=php7-pecl-yaml
-_extname=yaml
-pkgver=2.2.1
-pkgrel=0
-pkgdesc="YAML syntax bindings for PHP 7 - PECL"
-url="https://pecl.php.net/package/yaml"
-arch="all"
-license="MIT"
-depends="php7-common"
-makedepends="php7-dev yaml-dev"
-source="php-pecl-$_extname-$pkgver.tgz::https://pecl.php.net/get/$_extname-$pkgver.tgz"
-builddir="$srcdir/$_extname-$pkgver"
-provides="php7-yaml=$pkgver-r$pkgrel" # for backward compatibility
-replaces="php7-yaml" # for backward compatibility
-
-build() {
- phpize7
- ./configure \
- --prefix=/usr \
- --with-php-config=php-config7
- make
-}
-
-# Thanks to @TBK for https://github.com/php/pecl-file_formats-yaml/pull/29
-check() {
- make NO_INTERACTION=1 REPORT_EXIT_STATUS=1 test TESTS=--show-diff
-}
-
-package() {
- make INSTALL_ROOT="$pkgdir" install
- local _confdir="$pkgdir"/etc/php7/conf.d
- install -d $_confdir
- echo "extension=$_extname" > $_confdir/70_$_extname.ini
-}
-
-sha512sums="b171ca9ca108dc093fb0dda3bc9de821fdd8ddcf79d386baba02f367e331f42e6500f26e73577864cd5f8d12f8c9bfe01962fb8d1bb56fa26d6f0a1208ac5441 php-pecl-yaml-2.2.1.tgz"