aboutsummaryrefslogtreecommitdiffstats
path: root/community/php8-pecl-apcu/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/php8-pecl-apcu/APKBUILD')
-rw-r--r--community/php8-pecl-apcu/APKBUILD40
1 files changed, 0 insertions, 40 deletions
diff --git a/community/php8-pecl-apcu/APKBUILD b/community/php8-pecl-apcu/APKBUILD
deleted file mode 100644
index 667f27ce575..00000000000
--- a/community/php8-pecl-apcu/APKBUILD
+++ /dev/null
@@ -1,40 +0,0 @@
-# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
-# Maintainer: Andy Postnikov <apostnikov@gmail.com>
-pkgname=php8-pecl-apcu
-_extname=apcu
-pkgver=5.1.20
-pkgrel=0
-pkgdesc="PHP 8 extension APC User Cache - PECL"
-url="https://pecl.php.net/package/apcu"
-arch="all"
-license="PHP-3.01"
-depends="php8-common"
-makedepends="php8-dev"
-checkdepends="php8-pcntl php8-session"
-source="php-pecl-$_extname-$pkgver.tgz::https://pecl.php.net/get/$_extname-$pkgver.tgz"
-builddir="$srcdir/$_extname-$pkgver"
-
-build() {
- phpize8
- ./configure --prefix=/usr --with-php-config=php-config8
- make
-}
-
-check() {
- local _modules=/usr/lib/php8/modules
- make NO_INTERACTION=1 REPORT_EXIT_STATUS=1 test \
- PHP_TEST_SHARED_EXTENSIONS=" \
- -d extension=$_modules/pcntl.so \
- -d extension=modules/$_extname.so" TESTS=--show-diff
-}
-
-package() {
- make INSTALL_ROOT="$pkgdir"/ install
- install -D -m644 apc.php "$pkgdir"/usr/share/php8/apcu/apc.php
-
- local _confdir="$pkgdir"/etc/php8/conf.d
- install -d $_confdir
- echo "extension=$_extname" > $_confdir/$_extname.ini
-}
-
-sha512sums="3e10b7e5dc7481b1250610ef83954875f427b9114d6b232bad9064fc33d8c8906bcc317f94a6cfc9f76c720fa06a44270d259cf2ceef6c1ec9dcadc49254ee1b php-pecl-apcu-5.1.20.tgz"