aboutsummaryrefslogtreecommitdiffstats
path: root/community/php8-pecl-apcu
diff options
context:
space:
mode:
Diffstat (limited to 'community/php8-pecl-apcu')
-rw-r--r--community/php8-pecl-apcu/APKBUILD43
1 files changed, 0 insertions, 43 deletions
diff --git a/community/php8-pecl-apcu/APKBUILD b/community/php8-pecl-apcu/APKBUILD
deleted file mode 100644
index 7e7d270ac0e..00000000000
--- a/community/php8-pecl-apcu/APKBUILD
+++ /dev/null
@@ -1,43 +0,0 @@
-# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
-# Maintainer: Andy Postnikov <apostnikov@gmail.com>
-pkgname=php8-pecl-apcu
-_extname=apcu
-pkgver=5.1.19
-pkgrel=1
-pkgdesc="PHP 8 extension APC User Cache - PECL"
-url="https://pecl.php.net/package/apcu"
-arch="all"
-license="PHP-3.01"
-depends="php8-common"
-makedepends="php8-dev"
-checkdepends="php8-pcntl php8-session"
-source="$pkgname-$pkgver.tgz::https://pecl.php.net/get/$_extname-$pkgver.tgz
- fix-zero-ui.patch::https://github.com/krakjoe/apcu/commit/b8663e546d2b0ca2ec0f8f408b8e8665e52cb5b4.patch"
-builddir="$srcdir/$_extname-$pkgver"
-
-build() {
- phpize8
- ./configure --prefix=/usr --with-php-config=php-config8
- make
-}
-
-check() {
- local _modules=/usr/lib/php8/modules
- make NO_INTERACTION=1 REPORT_EXIT_STATUS=1 test \
- TESTS=--show-diff \
- PHP_TEST_SHARED_EXTENSIONS=" \
- -d extension=$_modules/pcntl.so \
- -d extension=modules/$_extname.so"
-}
-
-package() {
- make INSTALL_ROOT="$pkgdir"/ install
- install -D -m644 apc.php "$pkgdir"/usr/share/php8/apcu/apc.php
-
- local _confdir="$pkgdir"/etc/php8/conf.d
- install -d $_confdir
- echo "extension=$_extname.so" > $_confdir/$_extname.ini
-}
-
-sha512sums="45077e3bd0eac207539e2eafe21968c71f49b8c8920168dbafa87961b041f1d348b6bf1c130104744bc541e1f690854f0a29062e9520db81c04edeee3ef2ed99 php8-pecl-apcu-5.1.19.tgz
-b1da042db282876696cb578a2420ea8d299c559a16c330b0d3f97212a71da9f03239be8d4e0a14fcf85a669caa7370846d1f4e1aabce13e832ef7dcbd7a512c3 fix-zero-ui.patch"