aboutsummaryrefslogtreecommitdiffstats
path: root/community/php8-pecl-ast/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/php8-pecl-ast/APKBUILD')
-rw-r--r--community/php8-pecl-ast/APKBUILD36
1 files changed, 0 insertions, 36 deletions
diff --git a/community/php8-pecl-ast/APKBUILD b/community/php8-pecl-ast/APKBUILD
deleted file mode 100644
index c15ae26aff6..00000000000
--- a/community/php8-pecl-ast/APKBUILD
+++ /dev/null
@@ -1,36 +0,0 @@
-# Contributor: Andy Blyler <andy@blyler.cc>
-# Contributor: Fabio Ribeiro <fabiorphp@gmail.com>
-# Maintainer: Andy Postnikov <apostnikov@gmail.com>
-pkgname=php8-pecl-ast
-_extname=ast
-pkgver=1.0.16
-pkgrel=0
-pkgdesc="PHP extension exposing PHP 8 abstract syntax tree - PECL"
-url="https://pecl.php.net/package/ast"
-arch="all"
-license="BSD-3-Clause"
-depends="php8-common"
-makedepends="php8-dev"
-source="php-pecl-$_extname-$pkgver.tar.gz::https://pecl.php.net/get/$_extname-$pkgver.tgz"
-builddir="$srcdir"/$_extname-$pkgver
-
-build() {
- phpize8
- ./configure --prefix=/usr --with-php-config=/usr/bin/php-config8
- make
-}
-
-check() {
- make NO_INTERACTION=1 REPORT_EXIT_STATUS=1 test TESTS=--show-diff
-}
-
-package() {
- make INSTALL_ROOT="$pkgdir" install
- local _confdir="$pkgdir"/etc/php8/conf.d
- install -d $_confdir
- echo "extension=$_extname" > $_confdir/$_extname.ini
-}
-
-sha512sums="
-44b7bb5f752161831f5342283a491eff76e05e96f6679ff63ef20ef9192380290863d8689e4b5949af2eaf010f226c7f4b72a36625715a5a7e29867c1c78e121 php-pecl-ast-1.0.16.tar.gz
-"