aboutsummaryrefslogtreecommitdiffstats
path: root/community/php8-pecl-protobuf/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/php8-pecl-protobuf/APKBUILD')
-rw-r--r--community/php8-pecl-protobuf/APKBUILD36
1 files changed, 0 insertions, 36 deletions
diff --git a/community/php8-pecl-protobuf/APKBUILD b/community/php8-pecl-protobuf/APKBUILD
deleted file mode 100644
index f7b62e9cc25..00000000000
--- a/community/php8-pecl-protobuf/APKBUILD
+++ /dev/null
@@ -1,36 +0,0 @@
-# Contributor: TBK <alpine@jjtc.eu>
-# Maintainer: TBK <alpine@jjtc.eu>
-pkgname=php8-pecl-protobuf
-_extname=protobuf
-pkgver=3.18.1
-pkgrel=0
-pkgdesc="PHP 8 extension: Google's language-neutral, platform-neutral, extensible mechanism for serializing structured data - PECL"
-url="https://pecl.php.net/package/protobuf"
-arch="all"
-license="BSD-3-Clause"
-depends="php8-common"
-makedepends="php8-dev"
-source="php-pecl-$_extname-$pkgver.tgz::https://pecl.php.net/get/$_extname-$pkgver.tgz"
-builddir="$srcdir/$_extname-$pkgver"
-
-build() {
- phpize8
- ./configure --prefix=/usr --with-php-config=php-config8
- make
-}
-
-check() {
- # Test suite is not a part of pecl release.
- php8 -d extension=modules/$_extname.so --ri $_extname
-}
-
-package() {
- make INSTALL_ROOT="$pkgdir" install
- local _confdir="$pkgdir"/etc/php8/conf.d
- install -d $_confdir
- echo "extension=$_extname.so" > $_confdir/$_extname.ini
-}
-
-sha512sums="
-2f83cd204d902e9c67fc3a9120405f2140e2edb2169dcb4a70012c3875dd80d2ad8aa144ec2f43bec31ee11e78a4f5363b63a962c94f6973a0eec78dc5158aa4 php-pecl-protobuf-3.18.1.tgz
-"