aboutsummaryrefslogtreecommitdiffstats
path: root/community/php8-pecl-protobuf/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/php8-pecl-protobuf/APKBUILD')
-rw-r--r--community/php8-pecl-protobuf/APKBUILD36
1 files changed, 0 insertions, 36 deletions
diff --git a/community/php8-pecl-protobuf/APKBUILD b/community/php8-pecl-protobuf/APKBUILD
deleted file mode 100644
index 6588adfcc53..00000000000
--- a/community/php8-pecl-protobuf/APKBUILD
+++ /dev/null
@@ -1,36 +0,0 @@
-# Contributor: TBK <alpine@jjtc.eu>
-# Maintainer: TBK <alpine@jjtc.eu>
-pkgname=php8-pecl-protobuf
-_extname=protobuf
-pkgver=3.21.2
-pkgrel=0
-pkgdesc="PHP 8.0 extension: Google's language-neutral, platform-neutral, extensible mechanism for serializing structured data - PECL"
-url="https://pecl.php.net/package/protobuf"
-arch="all"
-license="BSD-3-Clause"
-depends="php8-common"
-makedepends="php8-dev"
-source="php-pecl-$_extname-$pkgver.tgz::https://pecl.php.net/get/$_extname-$pkgver.tgz"
-builddir="$srcdir/$_extname-$pkgver"
-
-build() {
- phpize8
- ./configure --prefix=/usr --with-php-config=php-config8
- make
-}
-
-check() {
- # Test suite is not a part of pecl release.
- php8 -d extension=modules/$_extname.so --ri $_extname
-}
-
-package() {
- make INSTALL_ROOT="$pkgdir" install
- local _confdir="$pkgdir"/etc/php8/conf.d
- install -d $_confdir
- echo "extension=$_extname.so" > $_confdir/$_extname.ini
-}
-
-sha512sums="
-d636f55051e202a6f906ec946b6005230b20a499b66d549aa5d3751beb87759c392473ba6a59d5f6f14e16b73eee94153546ccf5c797a9f27e35da98dd34fa9d php-pecl-protobuf-3.21.2.tgz
-"