aboutsummaryrefslogtreecommitdiffstats
path: root/community/php8-pecl-xdebug/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/php8-pecl-xdebug/APKBUILD')
-rw-r--r--community/php8-pecl-xdebug/APKBUILD49
1 files changed, 0 insertions, 49 deletions
diff --git a/community/php8-pecl-xdebug/APKBUILD b/community/php8-pecl-xdebug/APKBUILD
deleted file mode 100644
index 27362b8447b..00000000000
--- a/community/php8-pecl-xdebug/APKBUILD
+++ /dev/null
@@ -1,49 +0,0 @@
-# Contributor: Andy Postnikov <apostnikov@gmail.com>
-# Contributor: Valery Kartel <valery.kartel@gmail.com>
-# Contributor: Fabio Ribeiro <fabiorphp@gmail.com>
-# Maintainer: Andy Postnikov <apostnikov@gmail.com>
-pkgname=php8-pecl-xdebug
-_extname=xdebug
-pkgver=3.1.1
-pkgrel=0
-pkgdesc="PHP 8 extension that provides functions for function traces and profiling - PECL"
-url="https://pecl.php.net/package/xdebug"
-arch="all"
-license="PHP-3.0"
-depends="php8-common"
-makedepends="php8-dev"
-source="php-pecl-$_extname-$pkgver.tgz::https://pecl.php.net/get/$_extname-$pkgver.tgz"
-builddir="$srcdir/$_extname-$pkgver"
-provides="php8-xdebug=$pkgver-r$pkgrel" # for backward compatibility
-replaces="php8-xdebug" # for backward compatibility
-
-build() {
- phpize8
- ./configure --prefix=/usr --with-php-config=php-config8
- make
-}
-
-check() {
- # PECL package has no test suite.
- php8 -d zend_extension="$builddir"/modules/xdebug.so -r 'xdebug_info();'
-}
-
-package() {
- make INSTALL_ROOT="$pkgdir" install
-
- local _confdir="$pkgdir"/etc/php8/conf.d
- mkdir -p $_confdir
- # should go after opcache
- cat > $_confdir/50_$_extname.ini <<-EOF
- ; Uncomment and configure mode https://xdebug.org/docs/all_settings#xdebug.mode
- ;zend_extension=$_extname.so
- ;xdebug.mode=off
- EOF
-
- install -D -m644 -t "$pkgdir"/usr/share/php8/xdebug/ contrib/tracefile-analyser.php
- install -D -m644 -t "$pkgdir"/usr/share/vim/vimfiles/syntax/ contrib/xt.vim
-}
-
-sha512sums="
-ff0776272213358c40462f750d9a2019992e6e9cc57e92465cf5d7f74841745fe9b581c4c152923b71247fcad9c9678e1650936377c068be50060218497987fe php-pecl-xdebug-3.1.1.tgz
-"