aboutsummaryrefslogtreecommitdiffstats
path: root/community/php81-pecl-swoole/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/php81-pecl-swoole/APKBUILD')
-rw-r--r--community/php81-pecl-swoole/APKBUILD53
1 files changed, 0 insertions, 53 deletions
diff --git a/community/php81-pecl-swoole/APKBUILD b/community/php81-pecl-swoole/APKBUILD
deleted file mode 100644
index 9af1938963e..00000000000
--- a/community/php81-pecl-swoole/APKBUILD
+++ /dev/null
@@ -1,53 +0,0 @@
-# Maintainer: Andy Postnikov <apostnikov@gmail.com>
-pkgname=php81-pecl-swoole
-_extname=swoole
-pkgver=4.8.9
-pkgrel=0
-pkgdesc="Event-driven asynchronous and concurrent networking engine with high performance for PHP 8.1 - PECL"
-url="https://pecl.php.net/package/swoole"
-arch="all"
-license="Apache-2.0"
-depends="php81-curl php81-mysqlnd php81-openssl php81-sockets"
-makedepends="php81-dev openssl1.1-compat-dev nghttp2-dev c-ares-dev curl-dev"
-source="php-pecl-$_extname-$pkgver.tgz::https://pecl.php.net/get/$_extname-$pkgver.tgz"
-builddir="$srcdir"/$_extname-$pkgver
-subpackages="$pkgname-dev"
-replaces="php81-pecl-openswoole"
-
-case "$CARCH" in
- ppc64le|s390x) makedepends="$makedepends libucontext-dev" ;;
-esac
-
-
-build() {
- case "$CARCH" in
- ppc64le|s390x) export LDFLAGS="$LDFLAGS -lucontext" ;;
- esac
- phpize81
- ./configure --prefix=/usr \
- --with-php-config=php-config81 \
- --enable-mysqlnd \
- --enable-openssl --with-openssl-dir=/usr \
- --enable-sockets \
- --enable-swoole-curl \
- --enable-swoole-json \
- --enable-cares \
- --enable-http2
- make
-}
-
-check() {
- # needs extra services to test all suite
- php81 -d extension=modules/swoole.so --ri swoole
-}
-
-package() {
- make INSTALL_ROOT="$pkgdir" install
- local _confdir="$pkgdir"/etc/php81/conf.d
- install -d $_confdir
- echo "extension=$_extname" > $_confdir/50_$_extname.ini
-}
-
-sha512sums="
-4531fb87b9b3bf5bbd05b07f9f10a04ad1530ffd610ca899dd6731c557e82b235c70c2f3c2edc6c1b6ba0484a1594e0375ef6054291578a324fb3b61d0bca232 php-pecl-swoole-4.8.9.tgz
-"