aboutsummaryrefslogtreecommitdiffstats
path: root/community/php81-pecl-xhprof/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/php81-pecl-xhprof/APKBUILD')
-rw-r--r--community/php81-pecl-xhprof/APKBUILD57
1 files changed, 0 insertions, 57 deletions
diff --git a/community/php81-pecl-xhprof/APKBUILD b/community/php81-pecl-xhprof/APKBUILD
deleted file mode 100644
index 766693ebfde..00000000000
--- a/community/php81-pecl-xhprof/APKBUILD
+++ /dev/null
@@ -1,57 +0,0 @@
-# Contributor: Andy Postnikov <apostnikov@gmail.com>
-# Maintainer: Andy Postnikov <apostnikov@gmail.com>
-
-pkgname=php81-pecl-xhprof
-_extname=xhprof
-pkgver=2.3.5
-pkgrel=0
-pkgdesc="A Hierarchical Profiler for PHP 8.1 - PECL"
-url="https://pecl.php.net/package/xhprof"
-arch="all"
-license="Apache-2.0"
-depends="php81-common"
-makedepends="php81-dev"
-_assetsdepends="php81-ctype graphviz ghostscript-fonts"
-subpackages="$pkgname-assets::noarch"
-source="php-pecl-$_extname-$pkgver.tgz::https://pecl.php.net/get/$_extname-$pkgver.tgz"
-builddir="$srcdir/$_extname-$pkgver/extension"
-provides="php81-xhprof=$pkgver-r$pkgrel" # for backward compatibility
-replaces="php81-xhprof" # for backward compatibility
-
-build() {
- phpize81
- ./configure --with-php-config=php-config81
- make
-}
-
-check() {
- [ $CARCH = s390x ] && rm -fr tests/xhprof_005.phpt # sleeping longer in CI
- make NO_INTERACTION=1 REPORT_EXIT_STATUS=1 TESTS=--show-diff test
-}
-
-package() {
- make INSTALL_ROOT="$pkgdir" install
- local _confdir="$pkgdir"/etc/php81/conf.d
- install -d $_confdir
- cat > $_confdir/$_extname.ini <<-EOF
- extension=$_extname
- xhprof.output_dir=/tmp
- EOF
-}
-
-assets() {
- pkgdesc="A Hierarchical Profiler for PHP (UI assets)"
- depends="$_assetsdepends"
- provides="php81-xhprof-assets=$pkgver-r$pkgrel" # for backward compatibility
- replaces="php81-xhprof-assets" # for backward compatibility
-
- local _assetsdir="$subpkgdir"/usr/share/php81/xhprof
- install -d $_assetsdir
- cp -R "$builddir"/../xhprof_lib $_assetsdir
- cp -R "$builddir"/../xhprof_html $_assetsdir
- cp -R "$builddir"/../examples $_assetsdir
-}
-
-sha512sums="
-50ae6fb8d63ac8354b7887daecd1882f33e616cd1ef165b54d51f26fa93d2827f621e89d0d583979c453af5d66a83ddcbf0eb2d462df74ebb422294e601268f4 php-pecl-xhprof-2.3.5.tgz
-"