aboutsummaryrefslogtreecommitdiffstats
path: root/community/phpmyadmin/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/phpmyadmin/APKBUILD')
-rw-r--r--community/phpmyadmin/APKBUILD30
1 files changed, 23 insertions, 7 deletions
diff --git a/community/phpmyadmin/APKBUILD b/community/phpmyadmin/APKBUILD
index b9e04b14547..700f98946f7 100644
--- a/community/phpmyadmin/APKBUILD
+++ b/community/phpmyadmin/APKBUILD
@@ -1,16 +1,17 @@
# Contributor: Sergei Lukin <sergej.lukin@gmail.com>
# Contributor: Matt Smith <mcs@darkregion.net>
+# Contributor: William Desportes <williamdes@wdes.fr>
# Maintainer: Andy Postnikov <apostnikov@gmail.com>
pkgname=phpmyadmin
-pkgver=5.2.0
-pkgrel=0
+pkgver=5.2.1
+pkgrel=2
pkgdesc="A Web-based PHP tool for administering MySQL"
url="https://www.phpmyadmin.net/"
arch="noarch"
license="GPL-2.0-only AND MIT AND BSD-2-Clause"
-_php=php8
+_php=php83
depends="$_php $_php-mysqli $_php-bz2 $_php-ctype $_php-curl $_php-gd
- $_php-mbstring $_php-openssl $_php-session $_php-zip"
+ $_php-mbstring $_php-openssl $_php-session $_php-zip $_php-xmlwriter $_php-iconv"
makedepends="$depends_dev"
install="$pkgname.post-install"
subpackages="$pkgname-doc"
@@ -18,7 +19,7 @@ _fullpkgname=phpMyAdmin-$pkgver-all-languages
source="https://files.phpmyadmin.net/phpMyAdmin/$pkgver/$_fullpkgname.tar.xz
$pkgname.apache2.conf
"
-options="!check" # tests require running MySQL
+options="!check" # Test suite require phpunit to run.
# secfixes:
# 5.1.2-r0:
@@ -48,7 +49,7 @@ options="!check" # tests require running MySQL
# 4.8.2-r0:
# - CVE-2018-12581
# - CVE-2018-12613
-# 4.8.0.-r1:
+# 4.8.0-r1:
# - CVE-2018-10188
# 4.6.5.2-r0:
# - CVE-2016-9847
@@ -74,7 +75,22 @@ options="!check" # tests require running MySQL
builddir="$srcdir"/$_fullpkgname
+_change_vendor_config_var() {
+ grep -q -F "'${1}' => ${2}," "$builddir"/libraries/vendor_config.php
+ sed -i "s@'${1}' => ${2},@'${1}' => ${3},@" "$builddir"/libraries/vendor_config.php
+ grep -q -F "'${1}' => ${3}," "$builddir"/libraries/vendor_config.php
+ $_php -l "$builddir"/libraries/vendor_config.php 1>/dev/null
+}
+
build() {
+ # Set a custom version suffix
+ _change_vendor_config_var versionSuffix "''" "'+alpine-r${pkgrel}'"
+ # Disable searching for newer versions
+ _change_vendor_config_var versionCheckDefault "true" "false"
+ # Change the ChangeLog path (package: phpmyadmin-doc)
+ _change_vendor_config_var changeLogFile "ROOT_PATH . 'ChangeLog'" "'/usr/share/doc/phpmyadmin/ChangeLog'"
+ # Change the LICENSE path (package: phpmyadmin-doc)
+ _change_vendor_config_var licenseFile "ROOT_PATH . 'LICENSE'" "'/usr/share/doc/phpmyadmin/LICENSE'"
return 0
}
@@ -113,6 +129,6 @@ doc() {
}
sha512sums="
-69658f94908e279e80f7cb76ac108090d704f27bc3f3206ff7d69c0aac4119ee42696ce66f98be6bc11e3532ca0d47916c1a2a8c915c3af6d1e5be6aa1d925a5 phpMyAdmin-5.2.0-all-languages.tar.xz
+8b440d90d887fa0391810732cad2b4bf502f0e045324e1f159cb06e34dae4268febaef0a6a8ac0e58d0cb0f945f3497354313585f80555f199c609de378ca873 phpMyAdmin-5.2.1-all-languages.tar.xz
ba5776800f5c7b6cbb4ae594ec77c4d3e0d0bd319d109c676bd6c969054967baef99cab1a30c2efa26487b2ec03ef9b81d035a4323003565cffb19b08fdce9f5 phpmyadmin.apache2.conf
"