aboutsummaryrefslogtreecommitdiffstats
path: root/community/picom/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/picom/APKBUILD')
-rw-r--r--community/picom/APKBUILD60
1 files changed, 48 insertions, 12 deletions
diff --git a/community/picom/APKBUILD b/community/picom/APKBUILD
index 605830eb93a..c1f623cceef 100644
--- a/community/picom/APKBUILD
+++ b/community/picom/APKBUILD
@@ -1,30 +1,58 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=picom
-pkgver=8.2
-pkgrel=0
+pkgver=10.2
+pkgrel=1
pkgdesc="X Compositor (a fork of compton)"
url="https://github.com/yshui/picom"
-arch="all"
+# s390x: tests hang
+arch="all !s390x"
license="MIT AND MPL-2.0"
-makedepends="libx11-dev libxcomposite-dev libxinerama-dev libxdamage-dev
- libconfig-dev pcre-dev libxrandr-dev dbus-dev libdrm-dev mesa-dev meson
- libev-dev libxdg-basedir-dev pixman-dev xcb-util-renderutil-dev
- xcb-util-image-dev asciidoc uthash-dev"
+makedepends="
+ asciidoc
+ dbus-dev
+ libconfig-dev
+ libdrm-dev
+ libev-dev
+ libx11-dev
+ libxcomposite-dev
+ libxdamage-dev
+ libxdg-basedir-dev
+ libxinerama-dev
+ libxrandr-dev
+ mesa-dev
+ meson
+ pcre-dev
+ pixman-dev
+ uthash-dev
+ xcb-util-image-dev
+ xcb-util-renderutil-dev
+ "
+checkdepends="
+ dbus-x11
+ libffi-dev
+ py3-dbus-next
+ py3-wheel
+ py3-xcffib
+ python3
+ python3-dev
+ xvfb-run
+ "
subpackages="$pkgname-doc"
source="picom-$pkgver.tar.gz::https://github.com/yshui/picom/archive/v$pkgver.tar.gz"
-options="!check" # No tests defined in tests/ directory
-[ "$CARCH" = "riscv64" ] && options="$options textrels"
+# one test fails
+[ "$CARCH" = "ppc64le" ] && options="$options !check"
replaces="compton" # Backwards compatibility
provides="compton=$pkgver-r$pkgrel" # Backwards compatibility
build() {
abuild-meson \
- -Dbuild_docs=true \
+ -Db_lto=true \
+ -Dwith_docs=true \
build
- meson compile ${JOBS:+-j ${JOBS}} -C build
+ meson compile -C build
}
package() {
@@ -35,4 +63,12 @@ package() {
install -D -m644 "picom.sample.conf" "$pkgdir/etc/xdg/picom.conf.example"
}
-sha512sums="bdc6675e73a211075ee0df2b056342cabb19ad27fd73586f5216886f503cd994536845eb866f371e07a8dc0404346c67b899a14830e9b7cbc9c01cbd782f36b1 picom-8.2.tar.gz"
+check() {
+ export XDG_RUNTIME_DIR="$(mktemp -d -p "$builddir")"
+ xvfb-run -a build/src/picom --config picom.sample.conf --no-vsync --diagnostics
+ xvfb-run -a ./tests/run_tests.sh build/src/picom
+}
+
+sha512sums="
+9c0351fbe8a9e76533243c8e76f8e7d10c1e49292f1c8e6c06f31fb0b512542a67970abe803d061c953546ff8d3e704488c263002a5a831f68deb010caee481d picom-10.2.tar.gz
+"