aboutsummaryrefslogtreecommitdiffstats
path: root/community/plan9port/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/plan9port/APKBUILD')
-rw-r--r--community/plan9port/APKBUILD42
1 files changed, 15 insertions, 27 deletions
diff --git a/community/plan9port/APKBUILD b/community/plan9port/APKBUILD
index 8c93b357803..29db8fa0fdb 100644
--- a/community/plan9port/APKBUILD
+++ b/community/plan9port/APKBUILD
@@ -1,9 +1,9 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
pkgname=plan9port
-_commit=d0d440860f2000a1560abb3f593cdc325fcead4c
-pkgver=0_git20211019
-pkgrel=1
+pkgver=0_git20240110
+pkgrel=0
+_commit=be7c68f6954f7dcaa53403e0f600716f65a13d32
pkgdesc="Port of many Plan 9 libraries and programs to Unix"
url="https://9fans.github.io/plan9port/"
arch="all"
@@ -11,35 +11,17 @@ license="LPL-1.02"
makedepends="linux-headers libucontext-dev libxt-dev libx11-dev
fontconfig-dev libxext-dev perl"
options="!check" # upstream doesn't have a test suite
-subpackages="$pkgname-doc"
+subpackages="$pkgname-doc $pkgname-src::noarch"
source="$pkgname-$pkgver-$_commit.tar.gz::https://github.com/9fans/plan9port/archive/$_commit.tar.gz
no-html-man-pages.patch
libucontext.patch
+ o_largefile.patch
plan9.sh"
builddir="$srcdir/$pkgname-$_commit"
-# TODO: Consider moving sources files to a subpackage or remove them.
-
export CC9="${CC:-gcc}"
-export CC9FLAGS="$CFLAGS"
-
-prepare() {
- default_prepare
-
- # The code hardcodes the path /usr/local/plan9 in a bunch of
- # places, however, most of these are replaced with $PLAN9_TARGET
- # by the lib/moveplan9.sh script. Unfortunately, this script is
- # invoked after compilation and does thus not handle hardcoded
- # paths in a few C files. Fix these manually.
- #
- # See:
- #
- # * https://gitlab.alpinelinux.org/alpine/aports/-/merge_requests/26969
- # * https://github.com/9fans/plan9port/pull/532
- #
- find . -name '*.c' -exec grep "/usr/local/plan9" -l {} + | \
- xargs sed -i "s|/usr/local/plan9|/usr/lib/plan9|g"
-}
+# LDFLAGS are ignored otherwise
+export CC9FLAGS="$CFLAGS $LDFLAGS"
build() {
./INSTALL -b
@@ -72,9 +54,15 @@ doc() {
usr/lib/plan9/man/lookman.index
}
+src() {
+ pkgdesc="$pkgdesc (source files)"
+ amove usr/lib/plan9/src
+}
+
sha512sums="
-d236c53b73b41a6a86213a3ed1df4bdfb820d588f05cb4b69e5265f3ac47cd5c18b595ad3b7a01097649c268d8b8e9b45076574bc70f51be974e6c21402f64b2 plan9port-0_git20211019-d0d440860f2000a1560abb3f593cdc325fcead4c.tar.gz
-7b87ff69bfa26f9e478bc6816835705f873f259a29779c2c77ba15a65f97bb75677355837e63d4723dc8059a4b86d2ef06446b6b619f009ef81be20e3c6ef50f no-html-man-pages.patch
+c8749d55a8e1253c4ed566406e6ba56b6818b652935dd086cd169ee59816cedaf6ead4c3cfa90781357b339fedc422406ce55a2f08c2b65d0e8f06280ba9ce4f plan9port-0_git20240110-be7c68f6954f7dcaa53403e0f600716f65a13d32.tar.gz
+117c450854ebebfb9fc826c11fac5ef3f06185f4c28aee40eb12beeeaf300bd7b6be414d10a1d4a461f3983c721f7de7ca66a45b40aff6a95788fa859daf7da8 no-html-man-pages.patch
15c3427d36cf9dfaa58c301756d3a8c94ea3acc7edbe3d1b484032acad5c401691e159949844ce277d4bf90b3fc8a38ff8e7c92567b2084c697895f609f11008 libucontext.patch
+456da6462d8ee0efd4052cefffa18a642c49fea390a99bcc2da74bcf22895844dade3bdc991bb85d4ed558cd0894a44b51bdb1447a352189e9ca9028da2887e7 o_largefile.patch
1862807e8c45280fbd3e7827c253de093deb773d846713e3c46256e77c409b2d69cce44a2fe086d2776ebf5204707f84a3577324800173daa2f3d4fb3eae09f0 plan9.sh
"