aboutsummaryrefslogtreecommitdiffstats
path: root/community/plasma-browser-integration/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/plasma-browser-integration/APKBUILD')
-rw-r--r--community/plasma-browser-integration/APKBUILD27
1 files changed, 15 insertions, 12 deletions
diff --git a/community/plasma-browser-integration/APKBUILD b/community/plasma-browser-integration/APKBUILD
index 9990a81fdc7..b74fce62d6b 100644
--- a/community/plasma-browser-integration/APKBUILD
+++ b/community/plasma-browser-integration/APKBUILD
@@ -1,18 +1,19 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
pkgname=plasma-browser-integration
-pkgver=5.25.2
+pkgver=6.0.3
pkgrel=0
pkgdesc="Components necessary to integrate browsers into the Plasma Desktop"
# armhf blocked by extra-cmake-modules
-# s390x and riscv64 blocked by polkit -> kio
-# ppc64le blocked by kaccounts-integration
-arch="all !armhf !s390x !riscv64 !ppc64le"
+# ppc64le, s390x and riscv64 blocked by qt6-qtwebengine -> purpose
+arch="all !armhf !ppc64le !s390x !riscv64"
url="https://community.kde.org/Plasma/Browser_Integration"
license="GPL-3.0-or-later"
makedepends="
extra-cmake-modules
- kactivities-dev
kconfig-dev
kdbusaddons-dev
kfilemetadata-dev
@@ -20,9 +21,11 @@ makedepends="
kio-dev
knotifications-dev
krunner-dev
- plasma-workspace-dev
+ kstatusnotifieritem-dev
+ plasma-activities-dev
+ plasma-workspace-dev>=$pkgver
purpose-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
samurai
"
@@ -30,8 +33,9 @@ case "$pkgver" in
*.90*) _rel=unstable;;
*) _rel=stable;;
esac
-source="https://download.kde.org/$_rel/plasma/$pkgver/plasma-browser-integration-$pkgver.tar.xz"
subpackages="$pkgname-lang"
+_repo_url="https://invent.kde.org/plasma/plasma-browser-integration.git"
+source="https://download.kde.org/stable/plasma/$pkgver/plasma-browser-integration-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
@@ -42,8 +46,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -51,5 +54,5 @@ package() {
}
sha512sums="
-06804d4c5e4cc1266c2318767c185c6fb014e8942938b7191f65e7f8d36415ffaabe08616435ff0a6496ccc28c7250438941a21ed8655741f1548ce1765f8ff0 plasma-browser-integration-5.25.2.tar.xz
+5305aeeaec34a9fb88871aff8ebdd9561ffd7518fff94ad286a60c9b23d3ed8a6b3d9a23249734c9387f5c04ff2fbd20f9397513191abdf8a6b6a57956187458 plasma-browser-integration-6.0.3.tar.xz
"