aboutsummaryrefslogtreecommitdiffstats
path: root/community/plasma-browser-integration/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/plasma-browser-integration/APKBUILD')
-rw-r--r--community/plasma-browser-integration/APKBUILD12
1 files changed, 5 insertions, 7 deletions
diff --git a/community/plasma-browser-integration/APKBUILD b/community/plasma-browser-integration/APKBUILD
index 25c9ef63bfc..b31d836d5f4 100644
--- a/community/plasma-browser-integration/APKBUILD
+++ b/community/plasma-browser-integration/APKBUILD
@@ -1,24 +1,22 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-browser-integration
-pkgver=5.18.4
-_pkgver=5.18.4.1
+pkgver=5.18.5
pkgrel=0
pkgdesc="Components necessary to integrate browsers into the Plasma Desktop"
arch="all !armhf" # armhf blocked by extra-cmake-modules
url="https://community.kde.org/Plasma/Browser_Integration"
license="GPL-3.0-or-later"
makedepends="extra-cmake-modules qt5-qtbase-dev kio-dev ki18n-dev kconfig-dev kdbusaddons-dev knotifications-dev krunner-dev kactivities-dev purpose-dev kfilemetadata-dev"
-source="https://download.kde.org/stable/plasma/$pkgver/plasma-browser-integration-$_pkgver.tar.xz"
+source="https://download.kde.org/stable/plasma/$pkgver/plasma-browser-integration-$pkgver.tar.xz"
subpackages="$pkgname-lang"
-builddir="$srcdir/$pkgname-$_pkgver"
build() {
cmake -B build \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
- make -C build
+ cmake --build build
}
check() {
@@ -27,7 +25,7 @@ check() {
}
package() {
- DESTDIR="$pkgdir" make -C build install
+ DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="05fcc78f68a029862daaae816d2c95a14b7b3133c9ea00cfad7cac32337a6b1642b15f23313dec665686c928f0405d18cafa20b06d16afa1ae8ce752d74e9066 plasma-browser-integration-5.18.4.1.tar.xz"
+sha512sums="096bfc0940fa3a40fe5145078fe801e2436779ac3333e953a68f7a68d3d592e3978606b70f1678c83a0748221e4d992ce14e0cb72c671f242d13db41390e8730 plasma-browser-integration-5.18.5.tar.xz"