aboutsummaryrefslogtreecommitdiffstats
path: root/community/plasma-camera/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/plasma-camera/APKBUILD')
-rw-r--r--community/plasma-camera/APKBUILD23
1 files changed, 13 insertions, 10 deletions
diff --git a/community/plasma-camera/APKBUILD b/community/plasma-camera/APKBUILD
index 1a5ee0e70a0..3a806b90747 100644
--- a/community/plasma-camera/APKBUILD
+++ b/community/plasma-camera/APKBUILD
@@ -1,13 +1,12 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-camera
-pkgver=1.0_git20210328
-pkgrel=0
-_commit="78c2e161c31b07be15f67c53bb556c3100a956b6"
+pkgver=1.0_git20230430
+pkgrel=1
+_commit="a31c77fdf8878cdb848a394d86572c5d672e3c50"
pkgdesc="Camera application for Plasma Mobile"
# armhf blocked by qt5-qtdeclarative
-# mips64 and riscv64 blocked by gst-plugins-bad
-arch="all !armhf !mips64 !riscv64"
+arch="all !armhf"
url="https://invent.kde.org/plasma-mobile/plasma-camera"
license="GPL-3.0-or-later AND BSD-3-Clause"
depends="
@@ -18,21 +17,22 @@ depends="
"
makedepends="
extra-cmake-modules
- kcoreaddons-dev
- ki18n-dev
+ kcoreaddons5-dev
+ ki18n5-dev
kirigami2-dev
qt5-qtbase-dev
qt5-qtdeclarative-dev
qt5-qtquickcontrols2-dev
qt5-qtsvg-dev
+ samurai
"
checkdepends="appstream"
source="https://invent.kde.org/plasma-mobile/plasma-camera/-/archive/$_commit/plasma-camera-$_commit.tar.gz"
builddir="$srcdir/$pkgname-$_commit"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
@@ -46,4 +46,7 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="6b2c187be65f75481e425a3b499bab01034930ee81d15eb2eef99abaa5bef8e4e911c13ee454737d940413729f1c8a69ba5395ce0e672e20f7708fd8b3c7c43f plasma-camera-78c2e161c31b07be15f67c53bb556c3100a956b6.tar.gz"
+
+sha512sums="
+6ed77f3740619974be39297ae39b93e6e99c9ef98d224c0367b88b87ec5ca048f7fc6dbebac7b2c3901018ae25a5dcadf5e50aad822463da434dea590bc34b8b plasma-camera-a31c77fdf8878cdb848a394d86572c5d672e3c50.tar.gz
+"