aboutsummaryrefslogtreecommitdiffstats
path: root/community/plasma-dialer/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/plasma-dialer/APKBUILD')
-rw-r--r--community/plasma-dialer/APKBUILD49
1 files changed, 29 insertions, 20 deletions
diff --git a/community/plasma-dialer/APKBUILD b/community/plasma-dialer/APKBUILD
index 48851ab23d4..e76889752d2 100644
--- a/community/plasma-dialer/APKBUILD
+++ b/community/plasma-dialer/APKBUILD
@@ -1,54 +1,63 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-mobile
pkgname=plasma-dialer
-pkgver=21.05
-pkgrel=0
+pkgver=23.01.0
+pkgrel=8
pkgdesc="A dialer for Plasma Mobile"
# armhf blocked by extra-cmake-modules
-# s390x and mips64 blocked by oxygen-sounds
-arch="all !armhf !s390x !mips64"
+arch="all !armhf"
url="https://invent.kde.org/plasma-mobile/plasma-dialer"
license="GPL-2.0-or-later"
depends="
+ kirigami-addons
kirigami2
oxygen-sounds
- telepathy-ofono
"
makedepends="
extra-cmake-modules
- kcontacts-dev
- kcoreaddons-dev
- kdbusaddons-dev
- ki18n-dev
- knotifications-dev
- kpeople-dev
+ callaudiod-dev
+ kcontacts5-dev
+ kcoreaddons5-dev
+ kdbusaddons5-dev
+ ki18n5-dev
+ kio5-dev
+ kirigami-addons-dev
+ knotifications5-dev
+ kpeople5-dev
libphonenumber-dev
- libqofono-dev
- pulseaudio-dev
+ modemmanager-qt5-dev
+ pulseaudio-qt-dev
qt5-qtbase-dev
qt5-qtdeclarative-dev
- telepathy-qt-dev
+ qt5-qtfeedback-dev
+ qt5-qtquickcontrols2-dev
+ qtmpris-dev
+ samurai
"
subpackages="$pkgname-lang"
+_repo_url="https://invent.kde.org/plasma-mobile/plasma-dialer.git"
source="https://download.kde.org/stable/plasma-mobile/$pkgver/plasma-dialer-$pkgver.tar.xz"
options="!check" # No tests
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
-6a621d24a0d30f38c0f2622d580778aa2bc1ce74865bfdb5bb9cdb93729dd4f8c248db602aa5af230180fe523b719ae0277e442262d3e5d0dd6347fe07b40949 plasma-dialer-21.05.tar.xz
+df218ddf942560ac7eb7607e60425ed8fd19757f2a515d2e3d11dea30a35cc16e38a6cfc11873e74920ec32483ae5f270e085f05ac67b8c38ccc3e04a76f1e27 plasma-dialer-23.01.0.tar.xz
"