aboutsummaryrefslogtreecommitdiffstats
path: root/community/plasma-firewall/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/plasma-firewall/APKBUILD')
-rw-r--r--community/plasma-firewall/APKBUILD39
1 files changed, 20 insertions, 19 deletions
diff --git a/community/plasma-firewall/APKBUILD b/community/plasma-firewall/APKBUILD
index 50c73a370d6..5ab369a0d4d 100644
--- a/community/plasma-firewall/APKBUILD
+++ b/community/plasma-firewall/APKBUILD
@@ -1,53 +1,54 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
pkgname=plasma-firewall
-pkgver=5.22.4
+pkgver=6.0.3
pkgrel=0
pkgdesc="Control Panel for your system firewall"
-# armhf blocked by qt5-qtdeclarative
-# s390x, mips64 and riscv64 blocked by polkit -> kcmutils
-arch="all !armhf !s390x !mips64 !riscv64"
+# armhf blocked by qt6-qtdeclarative
+arch="all !armhf"
url="https://kde.org/plasma-desktop/"
license="GPL-2.0-or-later"
-depends="
- python3
- kirigami2
- "
+depends="kirigami"
makedepends="
extra-cmake-modules
kcmutils-dev
kcoreaddons-dev
kdeclarative-dev
ki18n-dev
- plasma-framework-dev
- qt5-qtbase-dev
- qt5-qtdeclarative-dev
- qt5-qtx11extras-dev
+ libplasma-dev
+ qt6-qtbase-dev
+ qt6-qtdeclarative-dev
+ samurai
"
+checkdepends="xvfb-run"
case "$pkgver" in
*.90*) _rel=unstable;;
*) _rel=stable;;
esac
-source="https://download.kde.org/$_rel/plasma/$pkgver/plasma-firewall-$pkgver.tar.xz"
subpackages="$pkgname-lang"
+_repo_url="https://invent.kde.org/plasma/plasma-firewall.git"
+source="https://download.kde.org/stable/plasma/$pkgver/plasma-firewall-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ xvfb-run -a ctest --test-dir build --output-on-failure
}
package() {
DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
-6863e369183d81d7ac381f0951dbf6b4c903b6ca1c5780c1bba80843b8f0650272059b1e3627762edb700162ac0488a3b07d159e86e78d1f0026f282815421fa plasma-firewall-5.22.4.tar.xz
+b2e202c736e46e2260538f7ed960e2b9a5c3cf8b59c0516c67bec04173a42d367e35d59cb68269e1a9a53909aa349f6b749e689eaf1f1cbccd3838531c713feb plasma-firewall-6.0.3.tar.xz
"