aboutsummaryrefslogtreecommitdiffstats
path: root/community/plasma-firewall/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/plasma-firewall/APKBUILD')
-rw-r--r--community/plasma-firewall/APKBUILD33
1 files changed, 16 insertions, 17 deletions
diff --git a/community/plasma-firewall/APKBUILD b/community/plasma-firewall/APKBUILD
index cb31c5cccf1..7c1a54df649 100644
--- a/community/plasma-firewall/APKBUILD
+++ b/community/plasma-firewall/APKBUILD
@@ -1,37 +1,37 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
pkgname=plasma-firewall
-pkgver=5.25.2
+pkgver=6.0.4
pkgrel=0
pkgdesc="Control Panel for your system firewall"
-# armhf blocked by qt5-qtdeclarative
-# s390x and riscv64 blocked by polkit -> kcmutils
-arch="all !armhf !s390x !riscv64"
+# armhf blocked by qt6-qtdeclarative
+arch="all !armhf"
url="https://kde.org/plasma-desktop/"
license="GPL-2.0-or-later"
-depends="
- python3
- kirigami2
- "
+depends="kirigami"
makedepends="
extra-cmake-modules
kcmutils-dev
kcoreaddons-dev
kdeclarative-dev
ki18n-dev
- plasma-framework-dev
- qt5-qtbase-dev
- qt5-qtdeclarative-dev
- qt5-qtx11extras-dev
+ libplasma-dev
+ qt6-qtbase-dev
+ qt6-qtdeclarative-dev
samurai
"
+checkdepends="xvfb-run"
case "$pkgver" in
*.90*) _rel=unstable;;
*) _rel=stable;;
esac
-source="https://download.kde.org/$_rel/plasma/$pkgver/plasma-firewall-$pkgver.tar.xz"
subpackages="$pkgname-lang"
+_repo_url="https://invent.kde.org/plasma/plasma-firewall.git"
+source="https://download.kde.org/stable/plasma/$pkgver/plasma-firewall-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
@@ -42,8 +42,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ xvfb-run -a ctest --test-dir build --output-on-failure
}
package() {
@@ -51,5 +50,5 @@ package() {
}
sha512sums="
-d462cc1aceed6b6c2aa2d88e7a213fec120e7dad6ea37b61031e38300600a688a1bd4ff0b0a979fe270b69723c891576ce490012975e5fffb55d65a0ca519750 plasma-firewall-5.25.2.tar.xz
+70b914f1dbe011e10a250f4a3ca84a0e324798ba5d74cd3f89adddb61e92a53b7fca95cee63f6065c84dc36a81f45cb091ed51156b23564f62fba89625340a7c plasma-firewall-6.0.4.tar.xz
"