aboutsummaryrefslogtreecommitdiffstats
path: root/community/plasma-firewall/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/plasma-firewall/APKBUILD')
-rw-r--r--community/plasma-firewall/APKBUILD39
1 files changed, 20 insertions, 19 deletions
diff --git a/community/plasma-firewall/APKBUILD b/community/plasma-firewall/APKBUILD
index 37ab83a965f..7c1a54df649 100644
--- a/community/plasma-firewall/APKBUILD
+++ b/community/plasma-firewall/APKBUILD
@@ -1,53 +1,54 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
pkgname=plasma-firewall
-pkgver=5.23.2
+pkgver=6.0.4
pkgrel=0
pkgdesc="Control Panel for your system firewall"
-# armhf blocked by qt5-qtdeclarative
-# s390x, mips64 and riscv64 blocked by polkit -> kcmutils
-arch="all !armhf !s390x !mips64 !riscv64"
+# armhf blocked by qt6-qtdeclarative
+arch="all !armhf"
url="https://kde.org/plasma-desktop/"
license="GPL-2.0-or-later"
-depends="
- python3
- kirigami2
- "
+depends="kirigami"
makedepends="
extra-cmake-modules
kcmutils-dev
kcoreaddons-dev
kdeclarative-dev
ki18n-dev
- plasma-framework-dev
- qt5-qtbase-dev
- qt5-qtdeclarative-dev
- qt5-qtx11extras-dev
+ libplasma-dev
+ qt6-qtbase-dev
+ qt6-qtdeclarative-dev
+ samurai
"
+checkdepends="xvfb-run"
case "$pkgver" in
*.90*) _rel=unstable;;
*) _rel=stable;;
esac
-source="https://download.kde.org/$_rel/plasma/$pkgver/plasma-firewall-$pkgver.tar.xz"
subpackages="$pkgname-lang"
+_repo_url="https://invent.kde.org/plasma/plasma-firewall.git"
+source="https://download.kde.org/stable/plasma/$pkgver/plasma-firewall-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ xvfb-run -a ctest --test-dir build --output-on-failure
}
package() {
DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
-6c6ab2d51d4a23290ce909a960451eb4cd45b2d5ef25f590e44182edf7b27c4c02961606a59cad65231a451507018b1740d671672ff1e54d53a859141ced158b plasma-firewall-5.23.2.tar.xz
+70b914f1dbe011e10a250f4a3ca84a0e324798ba5d74cd3f89adddb61e92a53b7fca95cee63f6065c84dc36a81f45cb091ed51156b23564f62fba89625340a7c plasma-firewall-6.0.4.tar.xz
"