aboutsummaryrefslogtreecommitdiffstats
path: root/community/plasma-framework/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/plasma-framework/APKBUILD')
-rw-r--r--community/plasma-framework/APKBUILD34
1 files changed, 0 insertions, 34 deletions
diff --git a/community/plasma-framework/APKBUILD b/community/plasma-framework/APKBUILD
deleted file mode 100644
index 3bff3883bc6..00000000000
--- a/community/plasma-framework/APKBUILD
+++ /dev/null
@@ -1,34 +0,0 @@
-# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
-pkgname=plasma-framework
-pkgver=5.70.1
-pkgrel=0
-pkgdesc="Plasma library and runtime components based upon KF5 and Qt5"
-arch="all !armhf" # armhf blocked by qt5-qtdeclarative
-url="https://community.kde.org/Frameworks"
-license="LGPL-2.1-or-later AND GPL-2.0-or-later"
-depends_dev="qt5-qtbase-dev qt5-qtdeclarative-dev qt5-qtquickcontrols2-dev kactivities-dev karchive-dev kconfig-dev kconfigwidgets-dev kcoreaddons-dev kdbusaddons-dev kdeclarative-dev kglobalaccel-dev kguiaddons-dev ki18n-dev kiconthemes-dev kio-dev kservice-dev kwindowsystem-dev kxmlgui-dev knotifications-dev kpackage-dev kirigami2-dev kwayland-dev"
-makedepends="$depends_dev extra-cmake-modules qt5-qttools-dev doxygen kdoctools-dev"
-checkdepends="xvfb-run mesa-dri-swrast hicolor-icon-theme"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/plasma-framework-$pkgver.tar.xz"
-subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
-options="!check" # 8 out of 13 tests fail
-
-build() {
- cmake -B "$builddir"/build \
- -DCMAKE_BUILD_TYPE=None \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DBUILD_QCH=ON
- cmake --build build
-}
-
-check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
-}
-
-package() {
- DESTDIR="$pkgdir" cmake --build build --target install
-}
-sha512sums="2b022f0e1e6abec8b7cf0ff77dd862a78f17692d17a78ad5a42a1a784c98a57070a5a721b44e808e299f374248769b90449201ae3c6dba17a292726e3b646930 plasma-framework-5.70.1.tar.xz"