aboutsummaryrefslogtreecommitdiffstats
path: root/community/plasma-framework/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/plasma-framework/APKBUILD')
-rw-r--r--community/plasma-framework/APKBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/community/plasma-framework/APKBUILD b/community/plasma-framework/APKBUILD
index 762d1981aef..d0220fec46f 100644
--- a/community/plasma-framework/APKBUILD
+++ b/community/plasma-framework/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-framework
pkgver=5.92.0
-pkgrel=0
+pkgrel=1
pkgdesc="Plasma library and runtime components based upon KF5 and Qt5"
# armhf blocked by qt5-qtdeclarative
# s390x and riscv64 blocked by polkit
@@ -33,6 +33,7 @@ depends_dev="
qt5-qtbase-dev
qt5-qtdeclarative-dev
qt5-qtquickcontrols2-dev
+ samurai
"
makedepends="$depends_dev
doxygen
@@ -50,8 +51,8 @@ subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
options="!check" # 8 out of 13 tests fail
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_QCH=ON
@@ -66,6 +67,7 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
6efbb9f03ec11804b12cda209dc665468cf6f56ecf712a136a5cf1ea2cb1deb1d427896770b12c18094a2d7f0ef69da9dcbe52b16ae2126e8382ade74d8ce54c plasma-framework-5.92.0.tar.xz
"