aboutsummaryrefslogtreecommitdiffstats
path: root/community/plasma-integration/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/plasma-integration/APKBUILD')
-rw-r--r--community/plasma-integration/APKBUILD34
1 files changed, 18 insertions, 16 deletions
diff --git a/community/plasma-integration/APKBUILD b/community/plasma-integration/APKBUILD
index c3c9067fd5e..33bb4c00345 100644
--- a/community/plasma-integration/APKBUILD
+++ b/community/plasma-integration/APKBUILD
@@ -1,18 +1,21 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
pkgname=plasma-integration
-pkgver=5.24.5
+pkgver=6.0.4
pkgrel=0
-pkgdesc="Qt Platform Theme integration plugins for the Plasma workspaces"
-# armhf blocked by qt5-qtdeclarative
-# s390x and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !riscv64"
+pkgdesc="Qt Platform Theme integration plugins for the Plasma workspace"
+# armhf blocked by qt6-qtdeclarative
+arch="all !armhf"
url="https://kde.org/plasma-desktop/"
license="(LGPL-2.1-only OR LGPL-3.0-only) AND LGPL-2.1-only AND ((LGPL-2.1-only WITH Nokia-Qt-exception-1.1) OR (GPL-3.0-only WITH Nokia-Qt-exception-1.1))"
depends="
+ font-hack
font-noto
+ qqc2-breeze-style
qqc2-desktop-style
- ttf-hack
"
makedepends="
breeze-dev
@@ -23,13 +26,13 @@ makedepends="
kiconthemes-dev
kio-dev
knotifications-dev
+ kstatusnotifieritem-dev
kwayland-dev
kwidgetsaddons-dev
kwindowsystem-dev
libxcursor-dev
- qt5-qtbase-dev
- qt5-qtquickcontrols2-dev
- qt5-qtx11extras-dev
+ plasma-wayland-protocols
+ qt6-qtbase-dev
samurai
"
checkdepends="xvfb-run"
@@ -38,12 +41,12 @@ case "$pkgver" in
*.90*) _rel=unstable;;
*) _rel=stable;;
esac
-source="https://download.kde.org/$_rel/plasma/$pkgver/plasma-integration-$pkgver.tar.xz"
subpackages="$pkgname-lang"
-options="!check" # Broken
+_repo_url="https://invent.kde.org/plasma/plasma-integration.git"
+source="https://download.kde.org/stable/plasma/$pkgver/plasma-integration-$pkgver.tar.xz"
build() {
- cmake -B build -G Ninja \
+ cmake -B build -DBUILD_QT5=OFF -G Ninja \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
@@ -53,13 +56,12 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
+ xvfb-run -a ctest --test-dir build --output-on-failure -E "(qmltests6|frameworkintegration-k(deplatformtheme|fontsettingsdata|filedialog|hintssettings|filedialogqml)_unittest6)"
}
package() {
DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
-6c60eff349d6b60fd8f781e162768d7cfb45d042687c1206f3f2c9e7af0c5719ff70555eff181782607ac53755844b0968ee7b9a75c87d6bd65b489a3a9dc348 plasma-integration-5.24.5.tar.xz
+80bd8d44ceb920109d971027f71eafbdc682972d7b0eb737504c840befd47ccd6dc1536e67e173d1df11b38bb91bd493351159de853fdd2b5035800846004833 plasma-integration-6.0.4.tar.xz
"