aboutsummaryrefslogtreecommitdiffstats
path: root/community/plasma-integration/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/plasma-integration/APKBUILD')
-rw-r--r--community/plasma-integration/APKBUILD37
1 files changed, 20 insertions, 17 deletions
diff --git a/community/plasma-integration/APKBUILD b/community/plasma-integration/APKBUILD
index 881162b1d6c..ed5aeeb97c7 100644
--- a/community/plasma-integration/APKBUILD
+++ b/community/plasma-integration/APKBUILD
@@ -1,18 +1,21 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
pkgname=plasma-integration
-pkgver=5.21.5
+pkgver=6.0.3
pkgrel=0
-pkgdesc="Qt Platform Theme integration plugins for the Plasma workspaces"
-# armhf blocked by qt5-qtdeclarative
-# s390x blocked by kconfigwidgets
-arch="all !armhf !s390x !mips64"
+pkgdesc="Qt Platform Theme integration plugins for the Plasma workspace"
+# armhf blocked by qt6-qtdeclarative
+arch="all !armhf"
url="https://kde.org/plasma-desktop/"
license="(LGPL-2.1-only OR LGPL-3.0-only) AND LGPL-2.1-only AND ((LGPL-2.1-only WITH Nokia-Qt-exception-1.1) OR (GPL-3.0-only WITH Nokia-Qt-exception-1.1))"
depends="
+ font-hack
font-noto
+ qqc2-breeze-style
qqc2-desktop-style
- ttf-hack
"
makedepends="
breeze-dev
@@ -23,13 +26,14 @@ makedepends="
kiconthemes-dev
kio-dev
knotifications-dev
+ kstatusnotifieritem-dev
kwayland-dev
kwidgetsaddons-dev
kwindowsystem-dev
libxcursor-dev
- qt5-qtbase-dev
- qt5-qtquickcontrols2-dev
- qt5-qtx11extras-dev
+ plasma-wayland-protocols
+ qt6-qtbase-dev
+ samurai
"
checkdepends="xvfb-run"
@@ -37,13 +41,13 @@ case "$pkgver" in
*.90*) _rel=unstable;;
*) _rel=stable;;
esac
-source="https://download.kde.org/$_rel/plasma/$pkgver/plasma-integration-$pkgver.tar.xz"
subpackages="$pkgname-lang"
-options="!check" # Broken
+_repo_url="https://invent.kde.org/plasma/plasma-integration.git"
+source="https://download.kde.org/stable/plasma/$pkgver/plasma-integration-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -DBUILD_QT5=OFF -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DCMAKE_DISABLE_FIND_PACKAGE_FontNotoSans=true \
@@ -52,13 +56,12 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
+ xvfb-run -a ctest --test-dir build --output-on-failure -E "(qmltests6|frameworkintegration-k(deplatformtheme|fontsettingsdata|filedialog|hintssettings|filedialogqml)_unittest6)"
}
package() {
DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
-655fee4335569325431e9fb7d368bdf82b43f1e0e0f727f95f11f481a81e8dbdcdc43470c1768b9ab5701159ffaf571b551edc57510a653e1c7fedc1c4216d92 plasma-integration-5.21.5.tar.xz
+cc8de168240b45fef9056fb9bc58d4471f510b47c1d572e063abdd1830d8a2f61e93c39cd3603f1ef9a09fae627791d2d9eff456b2cb94de7ee3467af6d8c5f0 plasma-integration-6.0.3.tar.xz
"