aboutsummaryrefslogtreecommitdiffstats
path: root/community/plasma-mobile/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/plasma-mobile/APKBUILD')
-rw-r--r--community/plasma-mobile/APKBUILD44
1 files changed, 27 insertions, 17 deletions
diff --git a/community/plasma-mobile/APKBUILD b/community/plasma-mobile/APKBUILD
index 7cb08fe8562..d719e72ce71 100644
--- a/community/plasma-mobile/APKBUILD
+++ b/community/plasma-mobile/APKBUILD
@@ -1,30 +1,33 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
pkgname=plasma-mobile
-pkgver=5.25.1
+pkgver=6.0.4
pkgrel=0
pkgdesc="Modules providing phone functionality for Plasma"
# armhf blocked by extra-cmake-modules
-# s390x and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !riscv64"
+arch="all !armhf"
url="https://www.plasma-mobile.org/"
license="GPL-2.0-or-later AND LGPL-2.1-or-later"
depends="
+ bluez-qt
breeze-icons
dbus-x11
- kactivities
+ kpipewire
+ kquickcharts
maliit-keyboard
+ plasma-activities
plasma-nano
- plasma-nm-mobile
+ plasma-nm
plasma-pa
plasma-settings
plasma-workspace
qqc2-breeze-style
- qt5-qtquickcontrols2
"
makedepends="
extra-cmake-modules
- kactivities-dev
kauth-dev
kbookmarks-dev
kcodecs-dev
@@ -36,6 +39,7 @@ makedepends="
kdeclarative-dev
ki18n-dev
kio-dev
+ kirigami-addons-dev
kitemviews-dev
kjobwidgets-dev
knotifications-dev
@@ -48,27 +52,31 @@ makedepends="
kwindowsystem-dev
kxmlgui-dev
libphonenumber-dev
+ libplasma-dev
modemmanager-qt-dev
networkmanager-qt-dev
- plasma-framework-dev
+ plasma-activities-dev
plasma-workspace-dev
- qt5-qtdeclarative-dev
+ qcoro-dev
+ qt6-qtdeclarative-dev
samurai
solid-dev
telepathy-qt-dev
"
-# TODO: Translations are lost in 5.24.1, re-enable in 5.24.2
-# subpackages="$pkgname-lang"
provides="plasma-phone-components=$pkgver-r$pkgrel" # For backwards compatibility
replaces="plasma-phone-components" # For backwards compatibility
+subpackages="$pkgname-lang"
+
case "$pkgver" in
*.90*) _rel=unstable;;
*) _rel=stable;;
esac
-source="https://download.kde.org/$_rel/plasma/$pkgver/plasma-mobile-$pkgver.tar.xz"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/plasma/plasma-mobile.git"
+source="https://download.kde.org/stable/plasma/$pkgver/plasma-mobile-$pkgver.tar.xz
+ 99-flashlight.rules
+ "
build() {
cmake -B build -G Ninja \
@@ -79,14 +87,16 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
DESTDIR="$pkgdir" cmake --install build
+
+ install -Dm644 "$srcdir"/99-flashlight.rules -t "$pkgdir"/usr/lib/udev/rules.d/
}
sha512sums="
-2daf3be122bec4e936d4c6907bb15e9506a5e5d6b60f4b984c5a341009b3c232c40c89871984e03d6a4ca01180544d090e11408a11b37fbd3fb328ea40cca841 plasma-mobile-5.25.1.tar.xz
+179ee8d029311a9e8328dbbce22d33bd3b929082d553931443b5dc6f0ae2dbbc54320a9dea1c23b956b3da4504b74322200402062912cc620b23c4d8cc4f418e plasma-mobile-6.0.4.tar.xz
+4badc25cbb7dc84d6af54cff5f3c09dcc37da86b7e930bdcab6d75f8dd90ef0dd9c8a3837ab696b1f4de9cad82d5e64ddd44904640a92e910a8f45524542be95 99-flashlight.rules
"