aboutsummaryrefslogtreecommitdiffstats
path: root/community/plasma-mobile/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/plasma-mobile/APKBUILD')
-rw-r--r--community/plasma-mobile/APKBUILD45
1 files changed, 28 insertions, 17 deletions
diff --git a/community/plasma-mobile/APKBUILD b/community/plasma-mobile/APKBUILD
index b0afa3fae8a..d30b024f948 100644
--- a/community/plasma-mobile/APKBUILD
+++ b/community/plasma-mobile/APKBUILD
@@ -1,30 +1,33 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
pkgname=plasma-mobile
-pkgver=5.24.5
+pkgver=6.0.3.1
pkgrel=0
pkgdesc="Modules providing phone functionality for Plasma"
# armhf blocked by extra-cmake-modules
-# s390x and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !riscv64"
+arch="all !armhf"
url="https://www.plasma-mobile.org/"
license="GPL-2.0-or-later AND LGPL-2.1-or-later"
depends="
+ bluez-qt
breeze-icons
dbus-x11
- kactivities
+ kpipewire
+ kquickcharts
maliit-keyboard
+ plasma-activities
plasma-nano
- plasma-nm-mobile
+ plasma-nm
plasma-pa
plasma-settings
plasma-workspace
qqc2-breeze-style
- qt5-qtquickcontrols2
"
makedepends="
extra-cmake-modules
- kactivities-dev
kauth-dev
kbookmarks-dev
kcodecs-dev
@@ -36,6 +39,7 @@ makedepends="
kdeclarative-dev
ki18n-dev
kio-dev
+ kirigami-addons-dev
kitemviews-dev
kjobwidgets-dev
knotifications-dev
@@ -48,26 +52,31 @@ makedepends="
kwindowsystem-dev
kxmlgui-dev
libphonenumber-dev
+ libplasma-dev
modemmanager-qt-dev
networkmanager-qt-dev
- plasma-framework-dev
- qt5-qtdeclarative-dev
+ plasma-activities-dev
+ plasma-workspace-dev
+ qcoro-dev
+ qt6-qtdeclarative-dev
samurai
solid-dev
telepathy-qt-dev
"
-# TODO: Translations are lost in 5.24.1, re-enable in 5.24.2
-# subpackages="$pkgname-lang"
provides="plasma-phone-components=$pkgver-r$pkgrel" # For backwards compatibility
replaces="plasma-phone-components" # For backwards compatibility
+subpackages="$pkgname-lang"
+
case "$pkgver" in
*.90*) _rel=unstable;;
*) _rel=stable;;
esac
-source="https://download.kde.org/$_rel/plasma/$pkgver/plasma-mobile-$pkgver.tar.xz"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/plasma/plasma-mobile.git"
+source="https://download.kde.org/stable/plasma/${pkgver%.*}/plasma-mobile-$pkgver.tar.xz
+ 99-flashlight.rules
+ "
build() {
cmake -B build -G Ninja \
@@ -78,14 +87,16 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
DESTDIR="$pkgdir" cmake --install build
+
+ install -Dm644 "$srcdir"/99-flashlight.rules -t "$pkgdir"/usr/lib/udev/rules.d/
}
sha512sums="
-fe5c6f80b784bfef6d9d64b33582c6a3f8e764d6d14007acbdb8cc21df42f633ef365ff4398f91a972309e07637b3d3113f2a88d78b32147a5605b02f84a35ed plasma-mobile-5.24.5.tar.xz
+51ec95a499c8c14183e90b4e9f5e977935c3cd4e10952af870a54afdd03ffe3016f8e901fd7a6d2225d82a692da0ae9ee50ba5f411897df033a2d26486c8c85e plasma-mobile-6.0.3.1.tar.xz
+4badc25cbb7dc84d6af54cff5f3c09dcc37da86b7e930bdcab6d75f8dd90ef0dd9c8a3837ab696b1f4de9cad82d5e64ddd44904640a92e910a8f45524542be95 99-flashlight.rules
"