aboutsummaryrefslogtreecommitdiffstats
path: root/community/plasma-nano/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/plasma-nano/APKBUILD')
-rw-r--r--community/plasma-nano/APKBUILD36
1 files changed, 21 insertions, 15 deletions
diff --git a/community/plasma-nano/APKBUILD b/community/plasma-nano/APKBUILD
index c8350d92657..41e63549c49 100644
--- a/community/plasma-nano/APKBUILD
+++ b/community/plasma-nano/APKBUILD
@@ -1,45 +1,51 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
pkgname=plasma-nano
-pkgver=5.21.2
+pkgver=6.0.3
pkgrel=0
pkgdesc="A minimal Plasma shell package intended for embedded devices"
# armhf blocked by extra-cmake-modules
-# s390x blocked by plasma-framework
-arch="all !armhf !s390x !mips64"
+arch="all !armhf"
url="https://invent.kde.org/kde/plasma-nano"
license="GPL-2.0-or-later AND LGPL-2.1-or-later"
-depends="qt5-qtvirtualkeyboard"
+depends="qt6-qtvirtualkeyboard"
makedepends="
extra-cmake-modules
+ kitemmodels-dev
kwayland-dev
kwindowsystem-dev
- plasma-framework-dev
- qt5-qtbase-dev
- qt5-qtdeclarative-dev
+ libplasma-dev
+ qt6-qtbase-dev
+ qt6-qtdeclarative-dev
+ samurai
"
case "$pkgver" in
*.90*) _rel=unstable;;
*) _rel=stable;;
esac
-source="https://download.kde.org/$_rel/plasma/$pkgver/plasma-nano-$pkgver.tar.xz"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/plasma/plasma-nano.git"
+source="https://download.kde.org/stable/plasma/$pkgver/plasma-nano-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="b5bbe3ba45ce879ebaf7753e5d8760d99da2b487bd2d2018edb8ca6dfe80ddab73c86ba27653b47989538f45bcfac059bc7541911d49ba4963ef7867b077d9ab plasma-nano-5.21.2.tar.xz"
+
+sha512sums="
+62ac5b715f4160f060391e2bbf57934cfade4a44cefdcf96da224fe50846ab912f2e3114dbc43497753344c3f445311e24234685d131d22dd3f90e0aaefa2790 plasma-nano-6.0.3.tar.xz
+"