aboutsummaryrefslogtreecommitdiffstats
path: root/community/plasma-nano/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/plasma-nano/APKBUILD')
-rw-r--r--community/plasma-nano/APKBUILD44
1 files changed, 31 insertions, 13 deletions
diff --git a/community/plasma-nano/APKBUILD b/community/plasma-nano/APKBUILD
index 13be524ea28..963d2cc2ab7 100644
--- a/community/plasma-nano/APKBUILD
+++ b/community/plasma-nano/APKBUILD
@@ -1,33 +1,51 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
pkgname=plasma-nano
-pkgver=5.20.3
+pkgver=6.0.4
pkgrel=0
pkgdesc="A minimal Plasma shell package intended for embedded devices"
# armhf blocked by extra-cmake-modules
-# s390x blocked by plasma-framework
-arch="all !armhf !s390x"
+arch="all !armhf"
url="https://invent.kde.org/kde/plasma-nano"
license="GPL-2.0-or-later AND LGPL-2.1-or-later"
-depends="qt5-qtvirtualkeyboard"
-makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtdeclarative-dev plasma-framework-dev kwindowsystem-dev kwayland-dev"
+depends="qt6-qtvirtualkeyboard"
+makedepends="
+ extra-cmake-modules
+ kitemmodels-dev
+ kwayland-dev
+ kwindowsystem-dev
+ libplasma-dev
+ qt6-qtbase-dev
+ qt6-qtdeclarative-dev
+ samurai
+ "
+
+case "$pkgver" in
+ *.90*) _rel=unstable;;
+ *) _rel=stable;;
+esac
+_repo_url="https://invent.kde.org/plasma/plasma-nano.git"
source="https://download.kde.org/stable/plasma/$pkgver/plasma-nano-$pkgver.tar.xz"
-options="!check" # No tests
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="9cd3e48561d09c464895e5618253a184889ba5d8543fa44d4dfd36879d4f506c94d4feec1481e123815104ef2a004f372db359049aea211df0125778ff819f3f plasma-nano-5.20.3.tar.xz"
+
+sha512sums="
+c1a15c1ac5d2001f5edc8d4806ae76102003291ea948ba3a2582c5396922ff905c0218f58c91c0eaed504dcd5f9f6fd9809197dc41331039d85c62547eef4e9e plasma-nano-6.0.4.tar.xz
+"