aboutsummaryrefslogtreecommitdiffstats
path: root/community/plasma-pa/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/plasma-pa/APKBUILD')
-rw-r--r--community/plasma-pa/APKBUILD45
1 files changed, 29 insertions, 16 deletions
diff --git a/community/plasma-pa/APKBUILD b/community/plasma-pa/APKBUILD
index bf36957c33e..f2ae8e16d13 100644
--- a/community/plasma-pa/APKBUILD
+++ b/community/plasma-pa/APKBUILD
@@ -1,40 +1,52 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
pkgname=plasma-pa
-pkgver=5.22.4
+pkgver=6.0.4
pkgrel=0
pkgdesc="Plasma applet for audio volume management using PulseAudio"
-# armhf blocked by qt5-qtdeclarative
-# s390x, mips64 and riscv64 blocked by polkit -> plasma-workspace
-arch="all !armhf !s390x !mips64 !riscv64"
+# armhf blocked by qt6-qtdeclarative
+arch="all !armhf"
url="https://kde.org/plasma-desktop/"
license="LGPL-2.1-only OR LGPL-3.0-only AND GPL-2.0-only"
-depends="pulseaudio kirigami2"
+depends="
+ kirigami
+ kquickcharts
+ pulseaudio
+ "
makedepends="
extra-cmake-modules
- qt5-qtbase-dev
- qt5-qtdeclarative-dev
+ kcmutils-dev
kcoreaddons-dev
kdeclarative-dev
kdoctools-dev
kglobalaccel-dev
- knotifications-dev
ki18n-dev
+ knotifications-dev
+ kstatusnotifieritem-dev
+ ksvg-dev
+ libcanberra-dev
+ libplasma-dev
plasma-workspace-dev
pulseaudio-dev
- libcanberra-dev
+ qt6-qtbase-dev
+ qt6-qtdeclarative-dev
+ samurai
"
case "$pkgver" in
*.90*) _rel=unstable;;
*) _rel=stable;;
esac
-source="https://download.kde.org/$_rel/plasma/$pkgver/plasma-pa-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/plasma/plasma-pa.git"
+source="https://download.kde.org/stable/plasma/$pkgver/plasma-pa-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DUSE_GCONF=OFF
@@ -42,13 +54,14 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ # applettest requires Selenium
+ ctest --test-dir build --output-on-failure -E "applettest"
}
package() {
DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
-73228e5b69aa9a6f9f6f11742c09daadfb0d8369766b774281a0a84a827348d44eb9b494e047652e8098fc59f577bd4f6f85dbf73a9969fec5e0c9a5caf5e39f plasma-pa-5.22.4.tar.xz
+a911574ad84ca67caa32b0f038abe687ad1073bbda691ecf5f4b79274ca9f7914284ca96f4ebf4088ed2d69c6eb5190cea0fe7bcbdf2406ce97ea09e7b845300 plasma-pa-6.0.4.tar.xz
"